summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-18 23:22:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-18 23:28:37 +0200
commit9cc588ab23c7f57b7e042af423a8949a0734400a (patch)
tree5c8e12b7e0f2e1363b35be1b389219e1f1d540a7 /app-pda
parentapp-pda/usbmuxd: restore v1.0.8_p20140530 (diff)
downloadgentoo-9cc588ab23c7f57b7e042af423a8949a0734400a.tar.gz
gentoo-9cc588ab23c7f57b7e042af423a8949a0734400a.tar.bz2
gentoo-9cc588ab23c7f57b7e042af423a8949a0734400a.zip
app-pda/libusbmuxd: restore v1.0.9
Fixes commit 9998a93ab8c86a06e8e9898b569ff5cfd789c694 which deleted last stable version. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libusbmuxd/Manifest1
-rw-r--r--app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-pda/libusbmuxd/Manifest b/app-pda/libusbmuxd/Manifest
index f64f038a9721..5b46379db698 100644
--- a/app-pda/libusbmuxd/Manifest
+++ b/app-pda/libusbmuxd/Manifest
@@ -1 +1,2 @@
DIST libusbmuxd-1.0.10.tar.bz2 292649 BLAKE2B 7ec9a576cb20f7e87cf1f31e57e66100c496e5809142d225df9b3cc295a71546bed2d90f41df3144f7316ce0aec5f08fad850c528e27f336bf96e9578bcffd04 SHA512 180cde2e9d0860d07d29813e68abf8ca807f75e98424b50acfc1ce941ba4260922959e1047a7d2bc754470c08ed55d0a15c9367487bd41c635a52b4fbf8ff535
+DIST libusbmuxd-1.0.9.tar.bz2 265940 BLAKE2B fbdb5ac441a3bcda41b752737f6a5fa9975948d67abf5b1edd9b3e3f749ea65486892af3c679cfcfa5f8d9052f8d35c6a5b0a3a95d07c65385ca28ff7a2b8633 SHA512 f50ee580ac9b4c5e55ab596aabb0bdc09f710cc58edba98699499998c44f2b2cf064792390f235b2221af494ce3233acda699652066b9297cc3cb4e9f8a1cfa4
diff --git a/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild b/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild
new file mode 100644
index 000000000000..53333b33da7c
--- /dev/null
+++ b/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+# tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/2" # based on SONAME of libusbmuxd.so
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="kernel_linux static-libs"
+
+RDEPEND=">=app-pda/libplist-1.11:=
+ virtual/libusb:1
+ !=app-pda/usbmuxd-1.0.9
+ !<app-pda/usbmuxd-1.0.8_p1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ local myeconfargs=( $(use_enable static-libs static) )
+ use kernel_linux || myeconfargs+=( --without-inotify )
+
+ autotools-utils_src_configure
+}