summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-17 03:12:08 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-21 02:16:56 +1100
commitfc5401a302646e82f62e58163c4396bb3a66dc2d (patch)
tree612c02555c453c42ead4741505247c74b4f00e33 /app-pda
parentmedia-sound/lastfmplayer: use correct version of lrelease (diff)
downloadgentoo-fc5401a302646e82f62e58163c4396bb3a66dc2d.tar.gz
gentoo-fc5401a302646e82f62e58163c4396bb3a66dc2d.tar.bz2
gentoo-fc5401a302646e82f62e58163c4396bb3a66dc2d.zip
app-pda: remove opensync packages
Gentoo-bug: 550234
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libopensync-plugin-file/Manifest3
-rw-r--r--app-pda/libopensync-plugin-file/libopensync-plugin-file-0.22.ebuild25
-rw-r--r--app-pda/libopensync-plugin-file/libopensync-plugin-file-0.36.ebuild27
-rw-r--r--app-pda/libopensync-plugin-file/libopensync-plugin-file-0.39.ebuild27
-rw-r--r--app-pda/libopensync-plugin-file/libopensync-plugin-file-9999.ebuild29
-rw-r--r--app-pda/libopensync-plugin-file/metadata.xml10
-rw-r--r--app-pda/libopensync-plugin-gnokii/Manifest2
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild29
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild20
-rw-r--r--app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild22
-rw-r--r--app-pda/libopensync-plugin-gnokii/metadata.xml5
-rw-r--r--app-pda/libopensync-plugin-gpe/Manifest2
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild20
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild19
-rw-r--r--app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild21
-rw-r--r--app-pda/libopensync-plugin-gpe/metadata.xml5
-rw-r--r--app-pda/libopensync-plugin-irmc/Manifest1
-rw-r--r--app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.22.ebuild37
-rw-r--r--app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-9999.ebuild36
-rw-r--r--app-pda/libopensync-plugin-irmc/metadata.xml12
-rw-r--r--app-pda/libopensync-plugin-moto/Manifest1
-rw-r--r--app-pda/libopensync-plugin-moto/libopensync-plugin-moto-0.22.ebuild34
-rw-r--r--app-pda/libopensync-plugin-moto/metadata.xml5
-rw-r--r--app-pda/libopensync-plugin-palm/Manifest1
-rw-r--r--app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch11
-rw-r--r--app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild36
-rw-r--r--app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild27
-rw-r--r--app-pda/libopensync-plugin-palm/metadata.xml10
-rw-r--r--app-pda/libopensync-plugin-python/Manifest1
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild31
-rw-r--r--app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild33
-rw-r--r--app-pda/libopensync-plugin-python/metadata.xml5
-rw-r--r--app-pda/libopensync-plugin-sunbird/Manifest1
-rw-r--r--app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild31
-rw-r--r--app-pda/libopensync-plugin-sunbird/metadata.xml10
-rw-r--r--app-pda/libopensync-plugin-synce-rra/Manifest1
-rw-r--r--app-pda/libopensync-plugin-synce-rra/libopensync-plugin-synce-rra-0.22.2.ebuild28
-rw-r--r--app-pda/libopensync-plugin-synce-rra/metadata.xml8
-rw-r--r--app-pda/libopensync-plugin-syncml/Manifest1
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild37
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild38
-rw-r--r--app-pda/libopensync-plugin-syncml/metadata.xml13
-rw-r--r--app-pda/libopensync-plugin-vformat/Manifest1
-rw-r--r--app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-0.39.ebuild26
-rw-r--r--app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-9999.ebuild28
-rw-r--r--app-pda/libopensync-plugin-vformat/metadata.xml9
-rw-r--r--app-pda/libopensync/Manifest3
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-Makefile.patch82
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-fbsd.patch20
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-pythonpath.patch63
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch13
-rw-r--r--app-pda/libopensync/libopensync-0.22-r1.ebuild97
-rw-r--r--app-pda/libopensync/libopensync-0.22.ebuild75
-rw-r--r--app-pda/libopensync/libopensync-0.36-r2.ebuild126
-rw-r--r--app-pda/libopensync/libopensync-0.39-r1.ebuild126
-rw-r--r--app-pda/libopensync/libopensync-9999.ebuild125
-rw-r--r--app-pda/libopensync/metadata.xml10
-rw-r--r--app-pda/libsyncml/Manifest1
-rw-r--r--app-pda/libsyncml/libsyncml-0.5.4.ebuild60
-rw-r--r--app-pda/libsyncml/libsyncml-9999.ebuild57
-rw-r--r--app-pda/libsyncml/metadata.xml12
-rw-r--r--app-pda/msynctool/Manifest1
-rw-r--r--app-pda/msynctool/metadata.xml12
-rw-r--r--app-pda/msynctool/msynctool-0.22.ebuild32
-rw-r--r--app-pda/multisync-gui/Manifest2
-rw-r--r--app-pda/multisync-gui/files/multisync-gui-0.92.0-cmake.patch41
-rw-r--r--app-pda/multisync-gui/files/multisync-gui-0.92.0-pixbuf-include.patch10
-rw-r--r--app-pda/multisync-gui/metadata.xml5
-rw-r--r--app-pda/multisync-gui/multisync-gui-0.91.0.ebuild27
-rw-r--r--app-pda/multisync-gui/multisync-gui-0.92.0_pre20080531.ebuild28
-rw-r--r--app-pda/osynctool/Manifest1
-rw-r--r--app-pda/osynctool/metadata.xml10
-rw-r--r--app-pda/osynctool/osynctool-0.39.ebuild28
-rw-r--r--app-pda/osynctool/osynctool-9999.ebuild30
74 files changed, 0 insertions, 1876 deletions
diff --git a/app-pda/libopensync-plugin-file/Manifest b/app-pda/libopensync-plugin-file/Manifest
deleted file mode 100644
index c71e7d470e4..00000000000
--- a/app-pda/libopensync-plugin-file/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST libopensync-plugin-file-0.22.tar.bz2 216890 SHA256 52231306a388f7ad49b273e0a90e3320811cfcad6c222669d05fe92e4c157825 SHA512 c8df060db87eb7eeb8e6dff6dc486eb4edd348bc22ec73e7d38930d9a1aef4f40e3d29f4d010ee7671fb1e59615512d92b9a3f3e49b714187c932d196460442e WHIRLPOOL 4af0243f88ef0cf2e84e46385375ee2b951470e783e4f0de2d8c36e1fc6f7b05f7f2b0a4e8032c1cf26e1cf4794b9751564b32295e0f778d5573477d2d1877b3
-DIST libopensync-plugin-file-0.36.tar.bz2 32942 SHA256 932726d69b398686b9d6a1e2afd53c537c03ae8a476df1b8b00ba1f8b4abbf44 SHA512 baa28eb811e916f77fd3c14748c0728e779815ad52755440220836b81fd20602c81c433071554f6e06bc9f3e114c32b354cbd8f68688d05025f39cde84c41e1c WHIRLPOOL 3acf4d367268b7bbbad6d028f23b3bf6f8668b21dc7ae14bda6b2b07349eea01b610a27ac3cc5c8a40d20d5ca6d331f1374381a931d74c21c2d15ba135c28046
-DIST libopensync-plugin-file-0.39.tar.bz2 53152 SHA256 26930abb2460b1b111f0acf3b16578613250f4ddd12e942a58163b252b96d1ab SHA512 b85061067c7157124f48be24965464e2aacabb12d1e9253077c01f466c74d3c0ec252f4ca905196f395f90ba5ca5474c6b60eb653e7905b6b5ec3aa45071c064 WHIRLPOOL 3c0107d8f6259aa750e08137a3d08c3e7198f5dc76a91f6c9909c1be55289fadd3adb3bea6be11a1857283cf04dd45925e2fb9e05286021cc09e268b8ba22f0e
diff --git a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.22.ebuild b/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.22.ebuild
deleted file mode 100644
index 7bbe39860ea..00000000000
--- a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.22.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-DESCRIPTION="OpenSync File Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}
diff --git a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.36.ebuild b/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.36.ebuild
deleted file mode 100644
index 40a72b874f6..00000000000
--- a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.36.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync File Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_install() {
- cmake-utils_src_install
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}
diff --git a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.39.ebuild b/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.39.ebuild
deleted file mode 100644
index 40a72b874f6..00000000000
--- a/app-pda/libopensync-plugin-file/libopensync-plugin-file-0.39.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync File Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_install() {
- cmake-utils_src_install
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}
diff --git a/app-pda/libopensync-plugin-file/libopensync-plugin-file-9999.ebuild b/app-pda/libopensync-plugin-file/libopensync-plugin-file-9999.ebuild
deleted file mode 100644
index 0630122a291..00000000000
--- a/app-pda/libopensync-plugin-file/libopensync-plugin-file-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync File Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/file-sync"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_install() {
- cmake-utils_src_install
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}
diff --git a/app-pda/libopensync-plugin-file/metadata.xml b/app-pda/libopensync-plugin-file/metadata.xml
deleted file mode 100644
index 0c317e5ffa3..00000000000
--- a/app-pda/libopensync-plugin-file/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
-</pkgmetadata>
-
diff --git a/app-pda/libopensync-plugin-gnokii/Manifest b/app-pda/libopensync-plugin-gnokii/Manifest
deleted file mode 100644
index f9edabcb0f8..00000000000
--- a/app-pda/libopensync-plugin-gnokii/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST libopensync-plugin-gnokii-0.22.tar.bz2 226990 SHA256 eb4902b4b7f9923f7644d350dd6cd84b562ebde8ca201e6284a29cff90c838a1 SHA512 a6ef418087d3803ebd4a6e68c8d2b6840667985d9cf8d8020efb98f675a519c3e1923329843de4d6fa72c7b35e23e7fef496e9067f941e24f12c30cd8d022059 WHIRLPOOL f26b8991b23d058f8e8589a93e111fdd81514fd755a0d43ff8c3201616c3f0d86b246a2f1bcc150fccbd5f1bcc2e925390b2ecdbe188b26293e89f8703f62b2a
-DIST libopensync-plugin-gnokii-0.36.tar.bz2 43782 SHA256 8674cc4a5df4a57d5d66756afc8492ac13ff335108ac225ee8164215a6feeb0b SHA512 527c5743cca879d3a9a34bfa16e10bf0d05e45dc0cc53b19a5e343ccf5f1985c38ee88f126da5c864dfc4f1c3ccee1d36c0d5d135907add7ad3d493373f28547 WHIRLPOOL a88e72fb7724af11f2bd32e57905da9438e0825d1f1c281667a012320f01919f6a5d9396fd188fa6db08e8963c3da69799f0b1b38a0b47ae88cdebfca1dfb566
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild
deleted file mode 100644
index dac0db2bad4..00000000000
--- a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.22.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit flag-o-matic
-
-DESCRIPTION="OpenSync Gnokii Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*
- >=app-mobilephone/gnokii-0.6.14"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- append-flags -Wno-error
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README
-}
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild
deleted file mode 100644
index 7b4421097eb..00000000000
--- a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-0.36.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync Gnokii Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*
- >=app-mobilephone/gnokii-0.6.14"
-RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild b/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild
deleted file mode 100644
index 271f281d0e9..00000000000
--- a/app-pda/libopensync-plugin-gnokii/libopensync-plugin-gnokii-9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync Gnokii Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/gnokii-sync"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*
- >=app-mobilephone/gnokii-0.6.14"
-RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gnokii/metadata.xml b/app-pda/libopensync-plugin-gnokii/metadata.xml
deleted file mode 100644
index 228404d3a4b..00000000000
--- a/app-pda/libopensync-plugin-gnokii/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-gpe/Manifest b/app-pda/libopensync-plugin-gpe/Manifest
deleted file mode 100644
index 2331400d311..00000000000
--- a/app-pda/libopensync-plugin-gpe/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST libopensync-plugin-gpe-0.22.tar.bz2 221836 SHA256 2f291a694bee5a502845b1b5ab465acdd524f4c288fcb4b4851982532a4ff56b SHA512 c1f8c94314898014fac174a11b965e9118ee86e2b168463ec52f10b39c4fa8baee365827505d7bd9d843c3049b34e41319329ab1d90ea7180ef5e75ebf312687 WHIRLPOOL 5ca25b1b3fe6882ef47cdfeed1dd7686f397814445f07eaac864cbd77982b278927d0f2d77f15ac5f5c13da0a0a3c6292e352f9b5b54eca8a28a47efa9bbc6b8
-DIST libopensync-plugin-gpe-0.36.tar.bz2 40935 SHA256 b919b1536ca0229881122ac63d98d02a8c8f038f8dbcad4fe173c466cca2cb05 SHA512 65bad63f66a35f8b9005e593ada82f82f59ed6d835e8eed9d249e812ad70efaac78f3c0f897293395f0612e82c54870d8df42cd8f0e267c860d063a3b1e0179b WHIRLPOOL 57a59bc3d94b123b3f4645de1c282f8b8b8771dc06bc6397e079c9209dd59cac0a2639accbfeee5a15d2e80fde676e7976f23457f8b4def330dc12e4a5df3e30
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild
deleted file mode 100644
index 7696e7edd1c..00000000000
--- a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.22.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-DESCRIPTION="OpenSync Gpe Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README
-}
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild
deleted file mode 100644
index 9d6812c61e3..00000000000
--- a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-0.36.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync Gpe Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild b/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild
deleted file mode 100644
index ab00aeec2c6..00000000000
--- a/app-pda/libopensync-plugin-gpe/libopensync-plugin-gpe-9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync Gpe Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/gpe"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
diff --git a/app-pda/libopensync-plugin-gpe/metadata.xml b/app-pda/libopensync-plugin-gpe/metadata.xml
deleted file mode 100644
index 228404d3a4b..00000000000
--- a/app-pda/libopensync-plugin-gpe/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-irmc/Manifest b/app-pda/libopensync-plugin-irmc/Manifest
deleted file mode 100644
index 39076716f36..00000000000
--- a/app-pda/libopensync-plugin-irmc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-irmc-0.22.tar.bz2 244648 SHA256 4bed935f596bd5ae11f6263a97e3cd25029a911f7e476e9b8f11b8036d89a0f6 SHA512 6ca23c98e1867682dc1d5e80c510ed6664bd362b72b36ff8706338f1d198c55541a034f01794c1138152a1b84886518e52e5648541863e62d879a0488ea9b722 WHIRLPOOL 0e654d60888f2c8d7fe304283fc8a4af6e08c3fa42287d64c12fec6344fdfff2f74ef541bca2d1bc548337cd9063330bb57120b8ac027453cb7a1fa096058e28
diff --git a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.22.ebuild b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.22.ebuild
deleted file mode 100644
index 1efd3629379..00000000000
--- a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.22.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-DESCRIPTION="OpenSync IrMC plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="+bluetooth irda"
-
-REQUIRED_USE="|| ( bluetooth irda )"
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2
- >=dev-libs/openobex-1.0[bluetooth?,irda?]
- bluetooth? ( net-wireless/bluez )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- $(use_enable bluetooth) \
- $(use_enable irda)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -exec rm -f {} + || die
- dodoc AUTHORS README
-}
diff --git a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-9999.ebuild b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-9999.ebuild
deleted file mode 100644
index 6522e5844e3..00000000000
--- a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils cmake-utils subversion
-
-DESCRIPTION="OpenSync IrMC plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/irmc-sync"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="bluetooth irda"
-
-REQUIRED_USE="|| ( bluetooth irda )"
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2
- >=dev-libs/openobex-1.0[bluetooth?,irda?]
- bluetooth? ( net-wireless/bluez )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_compile() {
- local mycmakeargs="
- $(cmake-utils_use_enable bluetooth BLUETOOTH)
- $(cmake-utils_use_enable irda IRDA)"
-
- cmake-utils_src_compile
-}
diff --git a/app-pda/libopensync-plugin-irmc/metadata.xml b/app-pda/libopensync-plugin-irmc/metadata.xml
deleted file mode 100644
index 8b8c775aede..00000000000
--- a/app-pda/libopensync-plugin-irmc/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-<maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
-</maintainer>
-<use>
- <flag name='irda'>Enable infrared support</flag>
-</use>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-moto/Manifest b/app-pda/libopensync-plugin-moto/Manifest
deleted file mode 100644
index 4431c7cad68..00000000000
--- a/app-pda/libopensync-plugin-moto/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-moto-0.22.tar.bz2 25846 SHA256 5081f7626fcc562a4478b83e30ec20bb2413e1c10866629dc85d7e6d9f25a0a5 SHA512 764cc6bb286e9d038949c5aa9064f0c3d7d85afbffe2767ee2f98fbb1ccbbb06375c065cd0df3a7dce8f6b333a4511ca3060773d6eae7eb470ea8c6018335eb1 WHIRLPOOL f6350a9639a825c68ad58a608cdb51982efb6673301d43f72a4dfb17a14360cece26edc3aa3b8476cc6c659aa0260594cddb3f6fb73b2adda993bf50f4b63c40
diff --git a/app-pda/libopensync-plugin-moto/libopensync-plugin-moto-0.22.ebuild b/app-pda/libopensync-plugin-moto/libopensync-plugin-moto-0.22.ebuild
deleted file mode 100644
index 23076d70314..00000000000
--- a/app-pda/libopensync-plugin-moto/libopensync-plugin-moto-0.22.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-
-PYTHON_DEPEND="2:2.6"
-
-inherit multilib python
-
-DESCRIPTION="Motorola plug-in for OpenSync"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bluetooth"
-
-RDEPEND="~app-pda/libopensync-${PV}
- ~app-pda/libopensync-plugin-python-${PV}
- dev-python/python-dateutil
- bluetooth? ( dev-python/pybluez )"
-DEPEND=""
-
-src_install() {
- # This is correct per README and OPENSYNC_PYTHONPLG_DIR variable in
- # configure.in at libopensync-plugin-python-0.22 package.
- insinto /usr/$(get_libdir)/opensync/python-plugins
- doins motosync.py || die
- exeinto /usr/share/opensync/defaults
- doexe moto-sync || die
- dodoc AUTHORS README
-}
diff --git a/app-pda/libopensync-plugin-moto/metadata.xml b/app-pda/libopensync-plugin-moto/metadata.xml
deleted file mode 100644
index 228404d3a4b..00000000000
--- a/app-pda/libopensync-plugin-moto/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-palm/Manifest b/app-pda/libopensync-plugin-palm/Manifest
deleted file mode 100644
index 0384fcb238f..00000000000
--- a/app-pda/libopensync-plugin-palm/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-palm-0.22.tar.bz2 232123 SHA256 a96c25ce7a68a1e6455a6f05fec20e8db77dab319de7e330145b3cfef8e0ce0d SHA512 fbcfc7fbc68bb1798dd02e38f4d1abe3d2c0f6d2b3a141d83d829454d43c45cdaf4d400b1226d7a8ed39d1304c68332eb9d0c77be635974c3d7f11207b952dd0 WHIRLPOOL 1850e4724a2b95916dc3afa983b865dc01d6a90b5a21e14772ead9f8bc22ae95bc5ca53f4eb83a1737b10b23f3fa7076c2b4737f709ecb435110f6c026d51342
diff --git a/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch b/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch
deleted file mode 100644
index 8182e6735be..00000000000
--- a/app-pda/libopensync-plugin-palm/files/libopensync-plugin-palm-include_pisock.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- acinclude.m4.org 2006-10-25 17:52:48.000000000 +0200
-+++ acinclude.m4 2006-10-25 17:53:15.000000000 +0200
-@@ -16,7 +16,7 @@
- PILOT_CFLAGS="-I$with_pilot_link/include"
- PILOT_LIBS="-L$with_pilot_link/lib -Wl,-R$with_pilot_link/lib -lpisock"
- else
-- PILOT_CFLAGS=""
-+ PILOT_CFLAGS="-I/usr/include/libpisock"
- PILOT_LIBS="-lpisock"
- fi
-
diff --git a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild
deleted file mode 100644
index 8d06aa84807..00000000000
--- a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-0.22.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit autotools eutils
-
-DESCRIPTION="OpenSync Palm Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- >=app-pda/pilot-link-0.11.8
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- # Patch fixing includedir for pisock
- epatch "${FILESDIR}/${PN}-include_pisock.patch"
- sed -i -e 's: -Werror::g' src/Makefile.am
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- find "${D}" -name '*.la' -exec rm -f {} + || die
- dodoc AUTHORS README
-}
diff --git a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild b/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild
deleted file mode 100644
index 4beb4ee98d5..00000000000
--- a/app-pda/libopensync-plugin-palm/libopensync-plugin-palm-9999.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync Palm Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/palm"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- >=app-pda/pilot-link-0.11.8
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="README"
diff --git a/app-pda/libopensync-plugin-palm/metadata.xml b/app-pda/libopensync-plugin-palm/metadata.xml
deleted file mode 100644
index 0c317e5ffa3..00000000000
--- a/app-pda/libopensync-plugin-palm/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
-</pkgmetadata>
-
diff --git a/app-pda/libopensync-plugin-python/Manifest b/app-pda/libopensync-plugin-python/Manifest
deleted file mode 100644
index 3648f1d13c0..00000000000
--- a/app-pda/libopensync-plugin-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-python-0.22.tar.bz2 215702 SHA256 49815fb498679cb0cb3713874da9ee60012753b25ff1dafc60cfca7cc38f3766 SHA512 ae52dace9ea82084d170f242ab7f1d1cc565a09eda45c71abc7a9e7fc726b963adbd121c731c22a105485162e9a9a924189f4669c6d13bf0156b42be0db211e7 WHIRLPOOL 400bd859bc58a8558a06197cd8dc63d56c6a038b81bccc2cffe7ae9a983447920986b8d0eae237a56d96e54fea5f0e88453fe90b44366d82d77230a43fe98b92
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild
deleted file mode 100644
index ca2191e5ed2..00000000000
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-0.22.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-
-inherit python
-
-DESCRIPTION="OpenSync Python Module"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}
diff --git a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild b/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
deleted file mode 100644
index 7103e2e8520..00000000000
--- a/app-pda/libopensync-plugin-python/libopensync-plugin-python-9999.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-
-inherit cmake-utils python subversion
-
-DESCRIPTION="OpenSync Python Module"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/python-module"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- # hardcoded python versions, use the module shipped with cmake (bug #276220)
- rm "${S}"/cmake/modules/FindPythonLibs.cmake || die
-}
diff --git a/app-pda/libopensync-plugin-python/metadata.xml b/app-pda/libopensync-plugin-python/metadata.xml
deleted file mode 100644
index 228404d3a4b..00000000000
--- a/app-pda/libopensync-plugin-python/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-sunbird/Manifest b/app-pda/libopensync-plugin-sunbird/Manifest
deleted file mode 100644
index b98bc7db75b..00000000000
--- a/app-pda/libopensync-plugin-sunbird/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-sunbird-0.22.tar.bz2 252354 SHA256 84beabde5440d4cd397f86f4092d9dd57d5a0a278623468a4a86004a1a920414 SHA512 95b4ed2fb438205ac3ecf7b5ffc2072b5dba42ea3a6ef63e08a43f18fe6a72e0fcd20c4be9d328b2999c9ee6cf0271cba8f52ad1ee4037a1563dda7d5d0cadec WHIRLPOOL 6feb80ec634bfb850fa653b6e178a7ac3320c6875a1d6a620af3abed77a201022f2f54bcabbcfad2b4fa50d8368301f8c0b82033fb4c4e7ac67869d93fab5505
diff --git a/app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild b/app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild
deleted file mode 100644
index f6d646867f7..00000000000
--- a/app-pda/libopensync-plugin-sunbird/libopensync-plugin-sunbird-0.22.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-DESCRIPTION="OpenSync Sunbird Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2
- net-libs/neon"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i -e 's: -Werror::g' src/Makefile.in
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- find "${D}" -name '*.la' -exec rm -f {} + || die
- dodoc AUTHORS README
-}
diff --git a/app-pda/libopensync-plugin-sunbird/metadata.xml b/app-pda/libopensync-plugin-sunbird/metadata.xml
deleted file mode 100644
index 0c317e5ffa3..00000000000
--- a/app-pda/libopensync-plugin-sunbird/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
-</pkgmetadata>
-
diff --git a/app-pda/libopensync-plugin-synce-rra/Manifest b/app-pda/libopensync-plugin-synce-rra/Manifest
deleted file mode 100644
index c897df8af55..00000000000
--- a/app-pda/libopensync-plugin-synce-rra/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-synce-rra-0.22.2.tar.gz 325388 SHA256 88bd7950960774bb1c626fc46b87bd11754f641475f3318328de3edf3f18b192 SHA512 5f5618e1742a48ab0de48585609997a2014ba586ebbac62f48df1e3724028c1359776953dbd3e29703d241a5c1dc44044d567f79481a041a014a00fbbc2ac51e WHIRLPOOL 07321e3785a8593078d52f3d0da2824cfa8cceaa60c708adc5cd9b936a416a9e8b29c50988877dc8f94ad12048a291a54a14e37ebe45e80ae6ae9ec9d9813028
diff --git a/app-pda/libopensync-plugin-synce-rra/libopensync-plugin-synce-rra-0.22.2.ebuild b/app-pda/libopensync-plugin-synce-rra/libopensync-plugin-synce-rra-0.22.2.ebuild
deleted file mode 100644
index 571fb05551c..00000000000
--- a/app-pda/libopensync-plugin-synce-rra/libopensync-plugin-synce-rra-0.22.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-DESCRIPTION="OpenSync SynCE RRA Plugin"
-HOMEPAGE="http://sourceforge.net/projects/synce/ http://www.opensync.org/"
-SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="=app-pda/libopensync-0.22*
- app-pda/synce-core
- >=dev-libs/glib-2
- >=dev-libs/librra-0.16
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
diff --git a/app-pda/libopensync-plugin-synce-rra/metadata.xml b/app-pda/libopensync-plugin-synce-rra/metadata.xml
deleted file mode 100644
index ba58102c22c..00000000000
--- a/app-pda/libopensync-plugin-synce-rra/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <upstream>
- <remote-id type="sourceforge">synce</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-syncml/Manifest b/app-pda/libopensync-plugin-syncml/Manifest
deleted file mode 100644
index b13c4d3df6f..00000000000
--- a/app-pda/libopensync-plugin-syncml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-syncml-0.39.tar.bz2 65557 SHA256 fd1bf079d804e7f8d16cec3eb743c0f7df3379f46ae037387b8b06be8392bbdd SHA512 9f7c48e6ec97f989228c6bf79bb4e5a81e5d078b613ce84d3254781fe6b17cde328aa0179463c8306a17aa8596d5ed0b06aee5bb5b43171b086729661beee91b WHIRLPOOL da77a036269371a2b1c56c16fc26455d919f73ecc1f800387d3d5c6c315863233947e785b7f6bc7c2170bff8ebea95ed1d580b92fb81f42b1dc41b30fdf17e41
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
deleted file mode 100644
index dfdf4365077..00000000000
--- a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync SyncML Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="http +obex"
-
-REQUIRED_USE="|| ( http obex )"
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2
- >=app-pda/libsyncml-0.5.0[obex?,http?]"
-DEPEND="${RDEPEND}"
-
-# FIXME: % tests passed, 2 tests failed out of 2
-RESTRICT="test"
-
-src_configure() {
- DOCS="AUTHORS"
-
- local mycmakeargs="
- $(cmake-utils_use_enable http HTTP)
- $(cmake-utils_use_enable obex OBEX)"
-
- cmake-utils_src_configure
-}
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild
deleted file mode 100644
index 0fb4dfa7241..00000000000
--- a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync SyncML Plugin"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/plugins/syncml/trunk"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="http +obex"
-
-REQUIRED_USE="|| ( http obex )"
-
-RDEPEND="~app-pda/libopensync-${PV}
- ~app-pda/libsyncml-${PV}[obex?,http?]
- dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}"
-
-RESTRICT="test"
-
-src_configure() {
- DOCS="AUTHORS"
-
- local mycmakeargs="
- $(cmake-utils_use_enable http HTTP)
- $(cmake-utils_use_enable obex OBEX)"
-
- cmake-utils_src_configure
-}
diff --git a/app-pda/libopensync-plugin-syncml/metadata.xml b/app-pda/libopensync-plugin-syncml/metadata.xml
deleted file mode 100644
index 498754bb006..00000000000
--- a/app-pda/libopensync-plugin-syncml/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-<maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
-</maintainer>
-<use>
- <flag name='http'>Enable http transports</flag>
- <flag name='obex'>Enable obex transports</flag>
-</use>
-</pkgmetadata>
diff --git a/app-pda/libopensync-plugin-vformat/Manifest b/app-pda/libopensync-plugin-vformat/Manifest
deleted file mode 100644
index 6424b5dbb95..00000000000
--- a/app-pda/libopensync-plugin-vformat/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libopensync-plugin-vformat-0.39.tar.bz2 106247 SHA256 33ee22ee28af622216efa99924e3af0956e4bca48381e634d94b5141d12b40b9 SHA512 d4ecc5cd7ec82471e1e299ceff6fe7f9f5c14aa33dc589c5f9c0f8147ae68b2f937a9ec4c8d66d79f6ea90864c174dd02655bbea9969ac695538dbbeb4204a4a WHIRLPOOL e785a3e734d34d361c29317f005e318b74d76834a85b050f6a5b2c0122c3c1a225d74c4363d6934dd154b03efe8000a63a8ee44793783ea6d0ced4b52e2f4bd5
diff --git a/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-0.39.ebuild b/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-0.39.ebuild
deleted file mode 100644
index 49d70e13278..00000000000
--- a/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-0.39.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync VFormat Plugin"
-HOMEPAGE="http://www.opensync.org"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# Don't pass
-RESTRICT="test"
-
-DOCS="AUTHORS ChangeLog"
diff --git a/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-9999.ebuild b/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-9999.ebuild
deleted file mode 100644
index 4226f1c81b6..00000000000
--- a/app-pda/libopensync-plugin-vformat/libopensync-plugin-vformat-9999.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="OpenSync VFormat Plugin"
-HOMEPAGE="http://www.opensync.org"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/format-plugins/vformat/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# Don't pass
-RESTRICT="test"
-
-DOCS="AUTHORS"
diff --git a/app-pda/libopensync-plugin-vformat/metadata.xml b/app-pda/libopensync-plugin-vformat/metadata.xml
deleted file mode 100644
index eedf953f447..00000000000
--- a/app-pda/libopensync-plugin-vformat/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
-</pkgmetadata>
diff --git a/app-pda/libopensync/Manifest b/app-pda/libopensync/Manifest
deleted file mode 100644
index 7ae420a0619..00000000000
--- a/app-pda/libopensync/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST libopensync-0.22.tar.bz2 489978 SHA256 3394bae1e3bcfe463d139a367ba5ebe73d968df128c871842dcb4965a725d0dc SHA512 90b6c7af9890d51bddfa5ce9ff5403f642d1deb7dc839e517366f9fd0afa5cd582b9a0e6e37d4a110f2aba7421da6705da0a761ad3ea40e9def3d3580f1b6aa2 WHIRLPOOL 8bd6110fd589c02ce97305a56b02ad5b9583d005ad2b9d3ebf994b47064d558247936f446df891fa508fdc23de43d1921e9e85e272e470ade88bbe94c05a0ad5
-DIST libopensync-0.36.tar.bz2 879868 SHA256 c686d27f0818e2d8cc6277ba123c74d7210e70fa2b320c5a828eaaedd598e908 SHA512 8f677b25df609320bc3e6ad021f686d4bc3a3ce9d2586ce8ae9148fd631b3835a3fd6fca6478750c968b7ea43744425d54918434b28b35120619de197be3ed1c WHIRLPOOL a1c02885d6a373fd824b3d4b3556c002e82f72ee120808250e975d96300db44641b736483e10f2a244dd521650441a75b2bd2b59a94cd9a0fc0c67d6e7e7aff5
-DIST libopensync-0.39.tar.bz2 1146955 SHA256 078f5d1d29774a190679e7e65e587f34cd8b001f07ea8745f31eba3f07edc430 SHA512 038c92e2599ca31d6633dd60eaf44e157887d285c8946740afb153c4afb98b718f3f73251212e1055452a793142d0d27e2edf510a9830308d20d9c7d4023c7e4 WHIRLPOOL a84f4eb14d81da23c8e725262b2e5b3bb233767bfb3154d609e614b17d8c8a3f2c97136551f56102568ff5b02ef1cf030260d1c16c77ca8b5dc703b9671c6cff
diff --git a/app-pda/libopensync/files/libopensync-0.22-Makefile.patch b/app-pda/libopensync/files/libopensync-0.22-Makefile.patch
deleted file mode 100644
index 579b792a49d..00000000000
--- a/app-pda/libopensync/files/libopensync-0.22-Makefile.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-https://bugs.gentoo.org/355291
-
---- a/opensync/Makefile.am
-+++ b/opensync/Makefile.am
-@@ -77,5 +77,5 @@ CLEANFILES = \
- *.bbg \
- *.da
-
--libopensync_la_LDFLAGS = @PACKAGE_LIBS@ @GCOV_LDFLAGS@
--libopensync_la_LIBADD = @XML_LIBS@
-+libopensync_la_LDFLAGS = @GCOV_LDFLAGS@
-+libopensync_la_LIBADD = @PACKAGE_LIBS@ @XML_LIBS@
---- a/osengine/Makefile.am
-+++ b/osengine/Makefile.am
-@@ -43,5 +43,5 @@ CLEANFILES = \
- *.bbg \
- *.da
-
--libosengine_la_LDFLAGS = $(PACKAGE_LIBS) -R $(libdir) @GCOV_LDFLAGS@
--libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la
-+libosengine_la_LDFLAGS = @GCOV_LDFLAGS@
-+libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PACKAGE_LIBS)
---- a/osplugin/Makefile.am
-+++ b/osplugin/Makefile.am
-@@ -9,8 +9,8 @@ libexec_PROGRAMS = osplugin
- ospluginincludedir = @OPENSYNC_HEADERDIR@
-
- osplugin_SOURCES = osplugin.c
--osplugin_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
--osplugin_LDADD = $(top_builddir)/opensync/libopensync.la
-+osplugin_LDFLAGS = @GCOV_LDFLAGS@
-+osplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
-
- CLEANFILES = \
- *.bb \
---- a/tools/Makefile.am
-+++ b/tools/Makefile.am
-@@ -9,24 +9,24 @@ bin_PROGRAMS = osyncdump osyncstress osyncplugin osynctest osyncbinary
- endif
-
- osyncdump_SOURCES = osyncdump.c
--osyncdump_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
--osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la
-+osyncdump_LDFLAGS = @GCOV_LDFLAGS@
-+osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
-
- osyncstress_SOURCES = osyncstress.c
--osyncstress_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
--osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
-+osyncstress_LDFLAGS = @GCOV_LDFLAGS@
-+osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
-
- osyncplugin_SOURCES = osyncplugin.c
--osyncplugin_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
--osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la
-+osyncplugin_LDFLAGS = @GCOV_LDFLAGS@
-+osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
-
- osynctest_SOURCES = osynctest.c
--osynctest_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
--osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
-+osynctest_LDFLAGS = @GCOV_LDFLAGS@
-+osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
-
- osyncbinary_SOURCES = osyncbinary.c
--osyncbinary_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir)
--osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la
-+osyncbinary_LDFLAGS =
-+osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
-
- CLEANFILES = \
- *.bb \
---- a/wrapper/Makefile.am
-+++ b/wrapper/Makefile.am
-@@ -22,5 +22,5 @@ osbindings_LTLIBRARIES = _opensync.la
- endif
-
- nodist__opensync_la_SOURCES = opensync_wrap.c
--_opensync_la_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ $(PYTHON_LDFLAGS) -R $(libdir) -module -avoid-version
--_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la
-+_opensync_la_LDFLAGS = -module -avoid-version
-+_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PYTHON_LDFLAGS) @PACKAGE_LIBS@ @XML_LIBS@
diff --git a/app-pda/libopensync/files/libopensync-0.22-fbsd.patch b/app-pda/libopensync/files/libopensync-0.22-fbsd.patch
deleted file mode 100644
index c9e7cdc9a8e..00000000000
--- a/app-pda/libopensync/files/libopensync-0.22-fbsd.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- libopensync-0.22/formats/vformats-xml/vformat.c 2007-06-17 10:54:54 +0000
-+++ libopensync-0.22/formats/vformats-xml/vformat.c 2007-06-17 10:55:30 +0000
-@@ -236,7 +236,7 @@
- if (charset) {
-
- cd = iconv_open("UTF-8", charset->str);
--#ifdef SOLARIS
-+#if defined(SOLARIS) || defined(__FreeBSD__) || defined(__NetBSD__)
- if (iconv(cd, (const char**)&inbuf, &inbytesleft, &p, &outbytesleft) != (size_t)(-1)) {
- #else
- if (iconv(cd, &inbuf, &inbytesleft, &p, &outbytesleft) != (size_t)(-1)) {
-@@ -264,7 +264,7 @@
-
- /* because inbuf is not UTF-8, we think it is ISO-8859-1 */
- cd = iconv_open("UTF-8", "ISO-8859-1");
--#ifdef SOLARIS
-+#if defined(SOLARIS) || defined(__FreeBSD__) || defined(__NetBSD__)
- if (iconv(cd, (const char**)&inbuf, &inbytesleft, &p, &outbytesleft) != (size_t)(-1)) {
- #else
- if (iconv(cd, &inbuf, &inbytesleft, &p, &outbytesleft) != (size_t)(-1)) {
diff --git a/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch b/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch
deleted file mode 100644
index abfb68cbdb3..00000000000
--- a/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff --git a/acinclude.m4 b/acinclude.m4
-index 2bf9951..a3b617c 100644
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -1008,9 +1008,9 @@ AC_DEFUN([AC_PROG_SWIG],[
- if test -z "$available_patch" ; then
- [available_patch=0]
- fi
-- if test $available_major -ne $required_major \
-- -o $available_minor -ne $required_minor \
-- -o $available_patch -lt $required_patch ; then
-+ if test $available_major -lt $required_major \
-+ -a $available_minor -lt $required_minor \
-+ -a $available_patch -lt $required_patch ; then
- AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
- SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
- else
-@@ -1114,7 +1114,7 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
- AC_MSG_CHECKING([for Python include path])
- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
- for i in "$python_path/include/python$PYTHON_VERSION/" "$python_path/include/python/" "$python_path/" ; do
-- python_path=`find $i -type f -name Python.h -print | sed "1q"`
-+ python_path=`find $i -type f -name Python.h -print 2>/dev/null | sed "1q"`
- if test -n "$python_path" ; then
- break
- fi
-@@ -1129,8 +1129,8 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
- # Check for Python library path
- AC_MSG_CHECKING([for Python library path])
- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
-- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
-- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
-+ for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/lib/" ; do
-+ python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print 2>/dev/null | sed "1q"`
- if test -n "$python_path" ; then
- break
- fi
-@@ -1142,16 +1142,21 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
- fi
- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -lpython$PYTHON_VERSION"])
- #
-- python_site=`echo $python_path | sed "s/config/site-packages/"`
-- AC_SUBST([PYTHON_SITE_PKG],[$python_site])
-+ # site-packages directory
-+ #
-+ AC_MSG_CHECKING(python site-packages)
-+ PYTHON_SITE_PKG=`$PYTHON -c "from distutils.sysconfig import get_python_lib; \
-+ print get_python_lib()"`
-+ AC_MSG_RESULT($PYTHON_SITE_PKG)
-+ AC_SUBST(PYTHON_SITE_PKG)
- #
- # libraries which must be linked in when embedding
- #
- AC_MSG_CHECKING(python extra libraries)
- PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
- conf = distutils.sysconfig.get_config_var; \
-- print conf('LOCALMODLIBS')+' '+conf('LIBS')"
-- AC_MSG_RESULT($PYTHON_EXTRA_LIBS)`
-+ print conf('LOCALMODLIBS')+' '+conf('LIBS')"`
-+ AC_MSG_RESULT($PYTHON_EXTRA_LIBS)
- AC_SUBST(PYTHON_EXTRA_LIBS)
- ])
- dnl as-ac-expand.m4 0.2.0
diff --git a/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch b/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch
deleted file mode 100644
index b1e42f39449..00000000000
--- a/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/wrapper/opensync.i b/wrapper/opensync.i
-index 623c0f4..8131158 100644
---- a/wrapper/opensync.i
-+++ b/wrapper/opensync.i
-@@ -82,7 +82,7 @@ typedef struct {} OSyncHashTable;
- %extend OSyncChange {
- OSyncChange(PyObject *obj=NULL) {
- OSyncChange *change = NULL;
-- if (obj)
-+ if ((obj) && (obj != Py_None))
- change = (OSyncChange *)PyCObject_AsVoidPtr(obj);
- else
- change = osync_change_new();
diff --git a/app-pda/libopensync/libopensync-0.22-r1.ebuild b/app-pda/libopensync/libopensync-0.22-r1.ebuild
deleted file mode 100644
index eb46001b821..00000000000
--- a/app-pda/libopensync/libopensync-0.22-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit autotools eutils python
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="amd64 hppa ppc ppc64 x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python"
-
-RDEPEND="dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- python? ( >=dev-lang/swig-1.3.17 )"
-# test? ( >=dev-libs/check-0.9.2 )"
-
-# Tests don't pass
-RESTRICT="test"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fbsd.patch
- epatch "${FILESDIR}"/${P}-pythonpath.patch
- epatch "${FILESDIR}"/${P}-swig-typeerror.patch
- epatch "${FILESDIR}"/${P}-Makefile.patch
- eautoreconf
-
- find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::' \
- -e 's: -R $(libdir)::g'
-
- use python && python_copy_sources
-}
-
-src_configure() {
- do_configure() {
- econf \
- --enable-engine \
- --enable-tools \
- $(use_enable python) \
- $(use_enable debug) \
- $(use_enable debug tracing)
- #$(use_enable test unit-tests)
-
- sed -i -e 's:^\(hardcode_libdir_flag_spec=\).*:\1"":g' \
- -e 's:^\(runpath_var=\).*:\1DIE_RPATH_DIE:g' \
- -e 's:func_apped:func_append:g' \
- libtool
- }
-
- use python && python_execute_function -s do_configure
- do_configure # do this even when USE=python - we need to generate Doxyfile
-}
-
-src_compile() {
- use python \
- && python_execute_function -d -s \
- || default
-
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- do_install() {
- emake DESTDIR="${D}" install || die
- }
-
- use python \
- && python_execute_function -s do_install \
- || do_install
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
- dodoc AUTHORS NEWS README TODO
-
- if use doc; then
- dohtml docs/html/* || die
- fi
-}
-
-pkg_postinst() {
- elog "Enabling the 'debug' useflag is required for bug reports."
- elog "Also see: http://www.opensync.org/wiki/tracing"
-}
diff --git a/app-pda/libopensync/libopensync-0.22.ebuild b/app-pda/libopensync/libopensync-0.22.ebuild
deleted file mode 100644
index 52f360d7524..00000000000
--- a/app-pda/libopensync/libopensync-0.22.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
-
-KEYWORDS="amd64 hppa ppc ppc64 x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python"
-#profiling" - needs tau - http://www.cs.uoregon.edu/research/tau/
-
-# Tests are not doing anything in 0.22
-# $(use_enable test unit-tests) \
-RESTRICT="test"
-
-RDEPEND=">=dev-db/sqlite-3
- >=dev-libs/glib-2
- dev-libs/libxml2
- python? ( >=dev-lang/python-2.2 )
- debug? ( >=dev-libs/check-0.9.2 )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- python? ( >=dev-lang/swig-1.3.17 )"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-fbsd.patch"
-}
-
-src_compile() {
- econf \
- --enable-engine \
- --enable-tools \
- $(use_enable python) \
- $(use_enable debug) \
- $(use_enable debug tracing) \
- || die "econf failed"
-
- emake || die "emake failed"
-
- use doc && doxygen Doxyfile
-}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
- use doc && dohtml docs/html/*
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.21"
- previous_less_than_0_21=$?
-}
-
-pkg_postinst() {
- elog "Building with 'debug' useflag is highly encouraged"
- elog "and requiered for bug reports."
- elog "Also see http://www.opensync.org/wiki/tracing"
-
- if [[ $previous_less_than_0_21 = 0 ]] ; then
- echo ""
- elog "You are updating from version prior to 0.21 and hence you need to rebuild your db."
- elog "How: http://www.opensync.org/wiki/FAQ#HowdoIcleanupasyncgroupfortesting"
- elog "Why: http://www.nabble.com/Not-Unique-UID-fix-in-subversion-tf3167800.html"
- fi
-}
diff --git a/app-pda/libopensync/libopensync-0.36-r2.ebuild b/app-pda/libopensync/libopensync-0.36-r2.ebuild
deleted file mode 100644
index 4cf96e4dcdc..00000000000
--- a/app-pda/libopensync/libopensync-0.36-r2.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit cmake-utils python
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python" # test
-
-RDEPEND="dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/libxslt"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen
- media-gfx/graphviz )
- python? ( >=dev-lang/swig-1.3.17 )"
-# test? ( >=dev-libs/check-0.9.2 )"
-
-DOCS="AUTHORS CODING README"
-
-# Tests don't pass
-RESTRICT="test"
-
-src_prepare() {
- # Has hardcoded python versions, use the module shipped with cmake instead
- # bug #276220
- rm "${S}"/cmake/modules/FindPythonLibs.cmake
-
- use python && python_copy_sources
-}
-
-src_configure() {
- local mycmakeargs="
- -DCMAKE_SKIP_RPATH=ON
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use_enable python WRAPPER)
- $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
- $(cmake-utils_use debug OPENSYNC_TRACE)"
-# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
-
- do_configure() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- # since we're using cmake's FindPythonLibs PYTHON_VERSION is
- # not defined
- sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
- "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
- fi
- cmake-utils_src_configure || die
- }
-
- use python \
- && python_execute_function -s do_configure \
- || do_configure
-}
-
-src_compile() {
- do_compile() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_compile || die
- }
-
- use python \
- && python_execute_function -s do_compile \
- || do_compile
-
- if use doc ; then
- cmake-utils_src_make DoxygenDoc || die
- fi
-}
-
-# TODO - fix
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
-
- if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
- die "Make test failed. See above for details."
- fi
-
- popd > /dev/null
-}
-
-src_install() {
- do_install() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_install || die
- }
-
- use python \
- && python_execute_function -s do_install \
- || do_install
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
-
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"
- dohtml docs/html/* || die
- fi
-}
-
-pkg_postinst() {
- elog "Enabling the 'debug' useflag is required for bug reports."
- elog "Also see: http://www.opensync.org/wiki/tracing"
-}
diff --git a/app-pda/libopensync/libopensync-0.39-r1.ebuild b/app-pda/libopensync/libopensync-0.39-r1.ebuild
deleted file mode 100644
index a7097518e2f..00000000000
--- a/app-pda/libopensync/libopensync-0.39-r1.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit cmake-utils python
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python" # test
-
-RDEPEND="dev-db/sqlite:3
- >=dev-libs/glib-2.12:2
- dev-libs/libxml2
- dev-libs/libxslt"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen
- media-gfx/graphviz )
- python? ( >=dev-lang/swig-1.3.17 )"
-# test? ( >=dev-libs/check-0.9.2 )"
-
-DOCS="AUTHORS CODING ChangeLog README"
-
-# Tests don't pass
-RESTRICT="test"
-
-src_prepare() {
- # Has hardcoded python versions, use the module shipped with cmake instead
- # bug #276220
- rm "${S}"/cmake/modules/FindPythonLibs.cmake
-
- use python && python_copy_sources
-}
-
-src_configure() {
- local mycmakeargs="
- -DCMAKE_SKIP_RPATH=ON
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use_enable python WRAPPER)
- $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
- $(cmake-utils_use debug OPENSYNC_TRACE)"
-# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
-
- do_configure() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- # since we're using cmake's FindPythonLibs PYTHON_VERSION is
- # not defined
- sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
- "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
- fi
- cmake-utils_src_configure || die
- }
-
- use python \
- && python_execute_function -s do_configure \
- || do_configure
-}
-
-src_compile() {
- do_compile() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_compile || die
- }
-
- use python \
- && python_execute_function -s do_compile \
- || do_compile
-
- if use doc ; then
- cmake-utils_src_make DoxygenDoc || die
- fi
-}
-
-# TODO - fix
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
-
- if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
- die "Make test failed. See above for details."
- fi
-
- popd > /dev/null
-}
-
-src_install() {
- do_install() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_install || die
- }
-
- use python \
- && python_execute_function -s do_install \
- || do_install
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
-
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"
- dohtml docs/html/* || die
- fi
-}
-
-pkg_postinst() {
- elog "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
- elog "the older app-pda/msynctool."
-}
diff --git a/app-pda/libopensync/libopensync-9999.ebuild b/app-pda/libopensync/libopensync-9999.ebuild
deleted file mode 100644
index f742631d491..00000000000
--- a/app-pda/libopensync/libopensync-9999.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit cmake-utils subversion python
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/trunk"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python" # test
-
-RDEPEND="dev-db/sqlite:3
- >=dev-libs/glib-2.12:2
- dev-libs/libxml2
- dev-libs/libxslt"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen
- media-gfx/graphviz )
- python? ( >=dev-lang/swig-1.3.17 )"
-# test? ( >=dev-libs/check-0.9.2 )
-
-DOCS="AUTHORS CODING ChangeLog README"
-
-# tests don't pass
-RESTRICT="test"
-
-src_prepare() {
- # Use cmake's instead - bug #276220
- rm "${S}"/cmake/modules/FindPythonLibs.cmake
-
- use python && python_copy_sources
-}
-
-src_configure() {
- local mycmakeargs="-DCMAKE_SKIP_RPATH=ON
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use_enable python WRAPPER)
- $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
- $(cmake-utils_use debug OPENSYNC_TRACE)"
-# $(cmake-utils_use test OPENSYNC_UNITTESTS)
-
- do_configure() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- # since we're using cmake's FindPythonLibs PYTHON_VERSION is not defined
- sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
- "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
- fi
- cmake-utils_src_configure || die
- }
-
- use python \
- && python_execute_function -s do_configure \
- || do_configure
-}
-
-src_compile() {
- do_compile() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_compile || die
- }
-
- use python \
- && python_execute_function -s do_compile \
- || do_compile
-
- if use doc ; then
- cmake-utils_src_make DoxygenDoc || die
- fi
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
-
- if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
- die "Make test failed. See above for details."
- fi
-
- popd > /dev/null
-}
-
-src_install() {
- do_install() {
- if use python; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
- CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
- fi
- cmake-utils_src_install || die
- }
-
- use python \
- && python_execute_function -s do_install \
- || do_install
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
-
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"
- dohtml docs/html/* || die
- fi
-}
-
-pkg_postinst() {
- elog "Building with 'debug' useflag is highly encouraged"
- elog "and requiered for bug reports."
- elog "Also see http://www.opensync.org/wiki/tracing"
-}
diff --git a/app-pda/libopensync/metadata.xml b/app-pda/libopensync/metadata.xml
deleted file mode 100644
index 0c317e5ffa3..00000000000
--- a/app-pda/libopensync/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
-</pkgmetadata>
-
diff --git a/app-pda/libsyncml/Manifest b/app-pda/libsyncml/Manifest
deleted file mode 100644
index cfe1de84db6..00000000000
--- a/app-pda/libsyncml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libsyncml-0.5.4.tar.bz2 289488 SHA256 5ee4c48923ae78489fd13a4329d6a86bcb020bb777f9bc1b35d152f197b748ff SHA512 aed0821d01eaaa3fef69d559820875591d3837b3968be24293fc41924b3599a2810d2b4cc29f82e6f4058a212eae5f71021bd96a046b568e7cb1a036ba8f37aa WHIRLPOOL f036a5bf991ed76fe66c709bcb5ac3cc9f974d91b2b2fcdba3fc21fbab6c7a9b69ce5675c6a65ccc73261e0ec3c732a8c4124a8764e656a288385f9847112fe6
diff --git a/app-pda/libsyncml/libsyncml-0.5.4.ebuild b/app-pda/libsyncml/libsyncml-0.5.4.ebuild
deleted file mode 100644
index b83a3e4690d..00000000000
--- a/app-pda/libsyncml/libsyncml-0.5.4.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="Implementation of the SyncML protocol"
-HOMEPAGE="http://libsyncml.opensync.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc http +obex test"
-
-# bluetooth and obex merged because bluetooth support in obex backend is
-# automagic, bug #285040
-# libsoup:2.2 is forced off to avoid automagic
-RDEPEND=">=dev-libs/glib-2.12
- >=dev-libs/libwbxml-0.11.0
- dev-libs/libxml2
- http? ( net-libs/libsoup:2.4 )
- obex? (
- net-wireless/bluez
- >=dev-libs/openobex-1.1[bluetooth] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( >=dev-libs/check-0.9.7 )"
-
-REQUIRED_USE="|| ( http obex )"
-
-DOCS="AUTHORS CODING ChangeLog RELEASE"
-
-src_prepare() {
- # https://bugs.gentoo.org/425738
- sed -i \
- -e '/include/s:wbxml.h:wbxml/&:' \
- libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHAVE_LIBSOUP22=OFF
- -DDOC_INSTALL_DIR=/usr/share/doc/${PF}
- $(cmake-utils_use_enable debug TRACE)
- $(cmake-utils_use_enable http HTTP)
- $(cmake-utils_use_enable obex OBEX)
- $(cmake-utils_use_enable obex BLUETOOTH)
- $(cmake-utils_use_enable test UNIT_TEST)
- )
-
- if use http && use obex; then
- # Doc builds with those previous USE flags only
- mycmakeargs+=( $(cmake-utils_use_build doc DOCUMENTATION) )
- fi
-
- cmake-utils_src_configure
-}
diff --git a/app-pda/libsyncml/libsyncml-9999.ebuild b/app-pda/libsyncml/libsyncml-9999.ebuild
deleted file mode 100644
index 1ad4e7a92cb..00000000000
--- a/app-pda/libsyncml/libsyncml-9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils subversion
-
-DESCRIPTION="Implementation of the SyncML protocol"
-HOMEPAGE="http://libsyncml.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/libsyncml/trunk"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="+debug doc http +obex test"
-
-# bluetooth and obex merged because bluetooth support in obex backend is
-# automagic, bug #285040
-# libsoup:2.2 is forced off to avoid automagic
-RDEPEND=">=dev-libs/glib-2.12
- >=dev-libs/libwbxml-0.11.0
- dev-libs/libxml2
- http? ( net-libs/libsoup:2.4 )
- obex? (
- net-wireless/bluez
- >=dev-libs/openobex-1.1[bluetooth] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( >=dev-libs/check-0.9.7 )"
-
-REQUIRED_USE="|| ( http obex )"
-
-DOCS="AUTHORS CODING ChangeLog RELEASE"
-
-src_prepare() {
- # https://bugs.gentoo.org/425738
- sed -i \
- -e '/include/s:wbxml.h:wbxml/&:' \
- libsyncml/parser/sml_wbxml_internals.h tests/mobiles/obex_mobile_ds_client.c || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHAVE_LIBSOUP22=OFF
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use_enable debug TRACE)
- $(cmake-utils_use_enable http HTTP)
- $(cmake-utils_use_enable obex OBEX)
- $(cmake-utils_use_enable obex BLUETOOTH)
- $(cmake-utils_use_enable test UNIT_TEST)
- )
-
- cmake-utils_src_configure
-}
diff --git a/app-pda/libsyncml/metadata.xml b/app-pda/libsyncml/metadata.xml
deleted file mode 100644
index 814a7c1c4fc..00000000000
--- a/app-pda/libsyncml/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <use>
- <flag name="http">Enable http transports</flag>
- <flag name="obex">Enable obex transports</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">libsyncml</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-pda/msynctool/Manifest b/app-pda/msynctool/Manifest
deleted file mode 100644
index f507c2909cc..00000000000
--- a/app-pda/msynctool/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST msynctool-0.22.tar.bz2 219787 SHA256 5a3008eaaf61dc9f7cc0cd0c762d700dfa8cc1aa65c07ec5bf12abe252f2d280 SHA512 69bc7e38f8d35e3eaebfb307832eab5e6a47a14197433482c8e1c9ccf6fc05070b0931e4063ad0511909b8a310237fc4bdf838acbd93877c55579499f754027f WHIRLPOOL 9e3b39514815e969b2e909f5f1f31e183ba8c49356f83c454566512487e1cd5db04c868c378f1e5aa2e3e559f7e51c637b92e0fd6adc2658f440c6f3cc91b843
diff --git a/app-pda/msynctool/metadata.xml b/app-pda/msynctool/metadata.xml
deleted file mode 100644
index a514ffc3d37..00000000000
--- a/app-pda/msynctool/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>pda</herd>
- <maintainer>
- <email>rhill@gentoo.org</email>
- <name>Ryan Hill</name>
- </maintainer>
- <longdescription lang="en">
- </longdescription>
-</pkgmetadata>
-
diff --git a/app-pda/msynctool/msynctool-0.22.ebuild b/app-pda/msynctool/msynctool-0.22.ebuild
deleted file mode 100644
index 4866994832f..00000000000
--- a/app-pda/msynctool/msynctool-0.22.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-DESCRIPTION="OpenSync msync tool"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/downloads/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- dev-libs/libxml2
- !app-pda/osynctool"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i -e 's: -Werror::g' \
- -e 's: -R $(libdir)::g' \
- tools/Makefile.in
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README
-}
diff --git a/app-pda/multisync-gui/Manifest b/app-pda/multisync-gui/Manifest
deleted file mode 100644
index 01f3aecb19f..00000000000
--- a/app-pda/multisync-gui/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST multisync-gui-0.91.0.tar.gz 112933 SHA256 958b9f2ecf4726095be7a8a5de5d24d325e487891dce56d02b566a93027f769d SHA512 66697d8d48d494d6a2aef7cf26cbe3b2602e9661b5c557acc15b2b0942062edcb7cba95c9c2192d097ff7a1a16f051ac613eb8dbcd2429287153fc8354f2fe2b WHIRLPOOL 137019f6d750b8045d0a35bd76dfe2330b896f4a6b413eeb66eeea64c87d5f39fb8306c8dfdb7c16add85b0c8bbdbde8599ff4edde0e37201bc0b9fb3d93d4b3
-DIST multisync-gui-0.92.0_pre20080531.tar.bz2 47265 SHA256 a7dcbcf2a1d367772e7bb83260cac8c66a524135bc96cef674d891cbec08de9d SHA512 f800f63f63283feb1fa7a2ff4f4beba4807c6ba24665a28b249ee5399a8a41062707c3cd04ff5e359c6f9c7f0f5ba4b5941d6a584befe4d8cc63b31f109fa858 WHIRLPOOL acee792dfa19d4ff039122681e2e5ff41dfc3857d3427ce1d77d5e7c2768fe527577f832f04faed47264eb4d8908e5e92367464f6812010d757adea9643642eb
diff --git a/app-pda/multisync-gui/files/multisync-gui-0.92.0-cmake.patch b/app-pda/multisync-gui/files/multisync-gui-0.92.0-cmake.patch
deleted file mode 100644
index 2edffd93e86..00000000000
--- a/app-pda/multisync-gui/files/multisync-gui-0.92.0-cmake.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Path-fixings.
-
-http://bugs.gentoo.org/237366
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,7 +1,7 @@
- PROJECT( multisyncgui C )
-
--SET( MULTISYNCGUI_GLADE_DIR "${CMAKE_INSTALL_PREFIX}/usr/share/multisync-gui/" )
--SET( MULTISYNCGUI_ICON_DIR "${CMAKE_INSTALL_PREFIX}/usr/share/pixmaps/multisync-gui/" )
-+SET( MULTISYNCGUI_GLADE_DIR "${CMAKE_INSTALL_PREFIX}/share/multisync-gui/" )
-+SET( MULTISYNCGUI_ICON_DIR "${CMAKE_INSTALL_PREFIX}/share/pixmaps/" )
-
- SET( MULTISYNCGUI_VERSION "0.36" )
- SET( MULTISYNCGUI_GLADE "${MULTISYNCGUI_GLADE_DIR}/multisyncgui.glade" )
---- a/misc/CMakeLists.txt
-+++ b/misc/CMakeLists.txt
-@@ -3,6 +3,6 @@ CONFIGURE_FILE( "${CMAKE_CURRENT_SOURCE_DIR}/multisyncgui.glade" "${CMAKE_CURREN
-
- ###### INSTALL ###################
-
--INSTALL( FILES ${CMAKE_CURRENT_BINARY_DIR}/multisyncgui.desktop DESTINATION "${CMAKE_INSTALL_PREFIX}/usr/share/applications/" )
-+INSTALL( FILES ${CMAKE_CURRENT_BINARY_DIR}/multisyncgui.desktop DESTINATION "${CMAKE_INSTALL_PREFIX}/share/applications/" )
- INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/multisyncgui.glade" DESTINATION "${MULTISYNCGUI_GLADE_DIR}" )
- INSTALL( FILES multisync.png DESTINATION ${MULTISYNCGUI_ICON_DIR} )
---- a/misc/multisyncgui.desktop
-+++ b/misc/multisyncgui.desktop
-@@ -3,10 +3,10 @@ Encoding=UTF-8
- Name=multisyncgui
- Comment=Synchronization program for personal information such as calendars, addressbooks etc.
- Comment[de]=Synchronisation von Organizern, PIMs und Mobiltelefonen
--Exec=@PREFIX@/bin/multisync-gui
-+Exec=@CMAKE_INSTALL_PREFIX@/bin/multisyncgui
- Terminal=false
- Type=Application
--Icon=@MULTISYNC_ICON_DIR@/multisync.png
-+Icon=@MULTISYNCGUI_ICON_DIR@/multisync.png
- StartupWMClass=multisync
- X-Desktop-File-Install-Version=0.3
- Categories=Application;Utility;X-Red-Hat-Base;
diff --git a/app-pda/multisync-gui/files/multisync-gui-0.92.0-pixbuf-include.patch b/app-pda/multisync-gui/files/multisync-gui-0.92.0-pixbuf-include.patch
deleted file mode 100644
index af88164a8e0..00000000000
--- a/app-pda/multisync-gui/files/multisync-gui-0.92.0-pixbuf-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Add gdk-pixbuf include dir (split out in gtk+-2.21).
-
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -1,4 +1,4 @@
--INCLUDE_DIRECTORIES( ${OPENSYNC_INCLUDE_DIRS} ${GTK2_INCLUDE_DIRS} ${LIBGLADE_INCLUDE_DIRS} ${LIBXML2_INCLUDE_DIRS} )
-+INCLUDE_DIRECTORIES( ${OPENSYNC_INCLUDE_DIRS} ${GTK2_INCLUDE_DIRS} ${LIBGLADE_INCLUDE_DIRS} ${LIBXML2_INCLUDE_DIRS} /usr/include/gdk-pixbuf-2.0 )
- LINK_DIRECTORIES( ${OPENSYNC_LIBRARY_DIRS} ${GTK2_LIBRARY_DIRS} ${LIBGLADE_LIBRARY_DIRS} ${LIBXML2_LIBRARY_DIRS} )
-
- SET( multisyncgui_SRCS
diff --git a/app-pda/multisync-gui/metadata.xml b/app-pda/multisync-gui/metadata.xml
deleted file mode 100644
index 228404d3a4b..00000000000
--- a/app-pda/multisync-gui/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-</pkgmetadata>
diff --git a/app-pda/multisync-gui/multisync-gui-0.91.0.ebuild b/app-pda/multisync-gui/multisync-gui-0.91.0.ebuild
deleted file mode 100644
index 0b9ea658fa7..00000000000
--- a/app-pda/multisync-gui/multisync-gui-0.91.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit toolchain-funcs
-
-DESCRIPTION="OpenSync multisync-gui"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="<=app-pda/libopensync-0.35
- >=gnome-base/libgnomeui-2
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=""
-
-src_configure() {
- CPPFLAGS="${CXXFLAGS}" CFLAGS="${CXXFLAGS}" ./configure --prefix=/usr
-}
diff --git a/app-pda/multisync-gui/multisync-gui-0.92.0_pre20080531.ebuild b/app-pda/multisync-gui/multisync-gui-0.92.0_pre20080531.ebuild
deleted file mode 100644
index e1fe569265a..00000000000
--- a/app-pda/multisync-gui/multisync-gui-0.92.0_pre20080531.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="OpenSync multisync-gui"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-0.36
- >=dev-libs/libxml2-2.6.30
- >=gnome-base/libglade-2.6.2:2.0
- >=x11-libs/gtk+-2.21:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.92.0-cmake.patch \
- "${FILESDIR}"/${PN}-0.92.0-pixbuf-include.patch
-}
diff --git a/app-pda/osynctool/Manifest b/app-pda/osynctool/Manifest
deleted file mode 100644
index d87cd8227ca..00000000000
--- a/app-pda/osynctool/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST osynctool-0.39.tar.bz2 55850 SHA256 9690bc7720fadd1517c56f04b480d99c87304a43dc6e04b89bf1f59bb7e6764d SHA512 3e814b5b0261c8c69da451d1ce8d8380ebb1058f134a6d47e9e863036d3321866f4a8c1f71d23b9552d0abe7317bc9df3afcc64e97b35f7091d28b3ba8c2f4b6 WHIRLPOOL 168524b6469020d73b7a14ed40c987854c8b849f1e7eb26e10910dfa5a37b7d80424ebe460c1bfc9aaa0703cc8672d9b2d873702b7b759e246b1496b67531426
diff --git a/app-pda/osynctool/metadata.xml b/app-pda/osynctool/metadata.xml
deleted file mode 100644
index 65fffc6ff83..00000000000
--- a/app-pda/osynctool/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>pda</herd>
-<longdescription lang="en">
-Command line interface for OpenSync.
-You can use this tool to synchronize your devices and applications using the OpenSync framework from the command line.
-</longdescription>
-</pkgmetadata>
-
diff --git a/app-pda/osynctool/osynctool-0.39.ebuild b/app-pda/osynctool/osynctool-0.39.ebuild
deleted file mode 100644
index 1e9e0e50cf7..00000000000
--- a/app-pda/osynctool/osynctool-0.39.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils
-
-DESCRIPTION="Command line interface for OpenSync"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- !app-pda/msynctool"
-DEPEND="${DEPEND}"
-
-DOCS="AUTHORS CODING"
-
-src_prepare() {
- sed -i -e 's:/etc/bash_completion.d:/share/bash-completion:g' \
- tools/CMakeLists.txt
-}
diff --git a/app-pda/osynctool/osynctool-9999.ebuild b/app-pda/osynctool/osynctool-9999.ebuild
deleted file mode 100644
index b4957991f6f..00000000000
--- a/app-pda/osynctool/osynctool-9999.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit cmake-utils subversion
-
-DESCRIPTION="Command line interface for OpenSync"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.opensync.org/osynctool/trunk"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="~app-pda/libopensync-${PV}
- dev-libs/glib:2
- !app-pda/msynctool"
-DEPEND="${DEPEND}"
-
-DOCS="AUTHORS CODING"
-
-src_prepare() {
- sed -i -e 's:/etc/bash_completion.d:/share/bash-completion:g' \
- tools/CMakeLists.txt
-}