summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-19 21:10:14 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-19 21:11:02 +0100
commit53a1c9db623b196b9ac5c099d25fdbf691ad6fa5 (patch)
tree93000d39b96ff59b48781d53c5e5b84907218c40 /app-portage/eclass-manpages/eclass-manpages-20180119.ebuild
parentdev-util/cppcheck: Rebuild on dev-libs/tinyxml2 subslot updates (thanks Danie... (diff)
downloadgentoo-53a1c9db623b196b9ac5c099d25fdbf691ad6fa5.tar.gz
gentoo-53a1c9db623b196b9ac5c099d25fdbf691ad6fa5.tar.bz2
gentoo-53a1c9db623b196b9ac5c099d25fdbf691ad6fa5.zip
app-portage/eclass-manpages: New snapshot.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-portage/eclass-manpages/eclass-manpages-20180119.ebuild')
-rw-r--r--app-portage/eclass-manpages/eclass-manpages-20180119.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/eclass-manpages/eclass-manpages-20180119.ebuild b/app-portage/eclass-manpages/eclass-manpages-20180119.ebuild
new file mode 100644
index 000000000000..8c46e176e6c5
--- /dev/null
+++ b/app-portage/eclass-manpages/eclass-manpages-20180119.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stabled. No need to change to ~arch.
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+DEPEND="app-arch/xz-utils"
+
+# How to create a snapshot and upload it to your dev-space:
+#
+# mkdir eclass-manpages-$(date +%Y%m%d)
+# cp "$(portageq get_repo_path / gentoo)"/eclass/*.eclass eclass-manpages-$(date +%Y%m%d)/
+# tar -cf eclass-manpages-$(date +%Y%m%d).tar eclass-manpages-$(date +%Y%m%d)
+# xz -e eclass-manpages-$(date +%Y%m%d).tar
+# scp eclass-manpages-$(date +%Y%m%d).tar.xz dev.gentoo.org:public_html/distfiles/
+#
+# Then copy the ebuild and update your name in SRC_URI ;-).
+
+src_compile() {
+ env ECLASSDIR="${S}" bash "${FILESDIR}"/eclass-to-manpage.sh || die
+}
+
+src_install() {
+ doman *.5
+}