summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-10 10:53:15 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-10 11:09:57 +0100
commit77e5d1d7f2370705232b07b3823c7fe515bc7d28 (patch)
tree15742e0d7b8955c0fbcde39f83b870de33457c43 /app-portage/gemato
parentmate-extra/*: Update Manifest hashes (diff)
downloadgentoo-77e5d1d7f2370705232b07b3823c7fe515bc7d28.tar.gz
gentoo-77e5d1d7f2370705232b07b3823c7fe515bc7d28.tar.bz2
gentoo-77e5d1d7f2370705232b07b3823c7fe515bc7d28.zip
app-portage/gemato: Split dependencies more correctly
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/gemato-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index 375377b795d5..ddcbd59df71b 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -16,16 +16,20 @@ EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
-IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3"
+IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3 test"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+MODULE_RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- portage-postsync? ( app-crypt/gentoo-keys )
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
-DEPEND="${RDEPEND}"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ portage-postsync? ( app-crypt/gentoo-keys )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
python_test() {
esetup.py test