summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-08-08 10:35:46 -0400
committerMike Pagano <mpagano@gentoo.org>2016-08-08 10:36:12 -0400
commit36acd04ef5f45a0689b5bd1d45ef591cbb375eda (patch)
tree113e81b03f4a00d7918a4bc4736d2e08a8c8db63 /app-portage
parentnet-misc/networkmanager: remove empty /run/NetworkManager only (diff)
downloadgentoo-36acd04ef5f45a0689b5bd1d45ef591cbb375eda.tar.gz
gentoo-36acd04ef5f45a0689b5bd1d45ef591cbb375eda.tar.bz2
gentoo-36acd04ef5f45a0689b5bd1d45ef591cbb375eda.zip
app-portage/portpeek: Add support for python 3.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portpeek/portpeek-2.1.20-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.20-r1.ebuild b/app-portage/portpeek/portpeek-2.1.20-r1.ebuild
new file mode 100644
index 000000000000..cc8685e208bb
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.20-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.3.2-r1
+ >=sys-apps/portage-2.2.26[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}