summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-26 02:50:12 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-26 02:52:19 -0500
commit9a80064e5bdb270313ad4a531e413b62d7374a60 (patch)
tree4576ed728427412345085d761c712ada0be834c3 /app-shells/bash/bash-4.1_p17.ebuild
parentmedia-libs/imlib2: set KEYWORDS in ebuild for stabilization #572884 (diff)
downloadgentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.tar.gz
gentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.tar.bz2
gentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.zip
app-shells/bash: enable USE=static support in SLOT-ed ebuilds
Diffstat (limited to 'app-shells/bash/bash-4.1_p17.ebuild')
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index ad19cf367709..1d34fdd98aca 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs mem-scramble +net nls +readline"
+IUSE="afs mem-scramble +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -88,10 +90,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since