summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-24 17:40:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-24 17:41:03 +0200
commite5a76c98a55a0ed14566f38a9cf78bd50e9b6591 (patch)
tree4ca207803bba7020b1f43563852f832ca4f4dd4d /app-shells/bash/bash-5.0_p18.ebuild
parentapp-shells/bash: Removed old (diff)
downloadgentoo-e5a76c98a55a0ed14566f38a9cf78bd50e9b6591.tar.gz
gentoo-e5a76c98a55a0ed14566f38a9cf78bd50e9b6591.tar.bz2
gentoo-e5a76c98a55a0ed14566f38a9cf78bd50e9b6591.zip
app-shells/bash: EAPI-7 conversion
Closes: https://bugs.gentoo.org/742575 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/bash/bash-5.0_p18.ebuild')
-rw-r--r--app-shells/bash/bash-5.0_p18.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-shells/bash/bash-5.0_p18.ebuild b/app-shells/bash/bash-5.0_p18.ebuild
index c40437fdc3a0..37017ab29296 100644
--- a/app-shells/bash/bash-5.0_p18.ebuild
+++ b/app-shells/bash/bash-5.0_p18.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-inherit eutils flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs multilib prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
+PLEVEL="${PV##*_p}"
+MY_PV="${PV/_p*}"
+MY_PV="${MY_PV/_/-}"
+MY_P="${PN}-${MY_PV}"
is_release() {
case ${PV} in
*_alpha*|*_beta*|*_rc*) return 1 ;;
@@ -19,7 +19,7 @@ is_release() {
}
[[ ${PV} != *_p* ]] && PLEVEL=0
patches() {
- local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
+ local opt=${1} plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
[[ ${plevel} -eq 0 ]] && return 1
eval set -- {1..${plevel}}
set -- $(printf "${pn}${pv/\.}-%03d " "$@")
@@ -58,7 +58,7 @@ RDEPEND="
${DEPEND}
"
# we only need yacc when the .y files get patched (bash42-005)
-#DEPEND+=" virtual/yacc"
+#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
@@ -90,8 +90,8 @@ src_prepare() {
# Clean out local libs so we know we use system ones w/releases.
if is_release ; then
- rm -rf lib/{readline,termcap}/*
- touch lib/{readline,termcap}/Makefile.in # for config.status
+ rm -rf lib/{readline,termcap}/* || die
+ touch lib/{readline,termcap}/Makefile.in || die # for config.status
sed -ri -e 's:\$[(](RL|HIST)_LIBSRC[)]/[[:alpha:]]*.h::g' Makefile.in || die
fi
@@ -100,7 +100,7 @@ src_prepare() {
# Avoid regenerating docs after patches #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
- touch -r . doc/*
+ touch -r . doc/* || die
eapply -p0 "${PATCHES[@]}"
eapply_user