summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-22 20:11:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-22 20:22:07 +0100
commit2e158f0bfb5f6e6314352f16886d8c0589fd8b3c (patch)
tree931f28c2d456406196bbb5af38ef7c12b4668a68 /app-shells/bashdb
parentdev-python/awscli: bump to v1.16.81 (diff)
downloadgentoo-2e158f0bfb5f6e6314352f16886d8c0589fd8b3c.tar.gz
gentoo-2e158f0bfb5f6e6314352f16886d8c0589fd8b3c.tar.bz2
gentoo-2e158f0bfb5f6e6314352f16886d8c0589fd8b3c.zip
app-shells/bashdb: bump to v4.4-1.0.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-shells/bashdb')
-rw-r--r--app-shells/bashdb/Manifest1
-rw-r--r--app-shells/bashdb/bashdb-4.4.1.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-shells/bashdb/Manifest b/app-shells/bashdb/Manifest
index 8dec0735bb61..2f70f2f1d7db 100644
--- a/app-shells/bashdb/Manifest
+++ b/app-shells/bashdb/Manifest
@@ -3,3 +3,4 @@ DIST bashdb-4.4-0.92.tar.bz2 678961 BLAKE2B a47e964653238452fcad6f4e098df64de4d2
DIST bashdb-4.4-0.94.tar.bz2 810610 BLAKE2B fa3a68349b0ab64e17c094c34b82c8ba054a86f83452bab50a55bc9f63181459fd49a7a39e2e7a7c66063ac291b8f2a03d4ba6b834a3d5869d2fe9b099f4eb2b SHA512 97e7d057f16d90d7f1677e1b29d2467d5ee263e9aaad64e2d7a8b8a19b3f3ca68023f23a45faea235fdba57e803fae762a19aab67f650b81e868a8a01c5b1fb7
DIST bashdb-4.4-1.0.0-missing-test-files.tar.xz 996 BLAKE2B 7ea67884cceda11559cf49355645cad2cfd485537643ad2fa05398518f498163596b6f591756bedd0e7b7e013fed3c6a031e245d15cd0cf316d42ef4f5c8b3e6 SHA512 e19d41569c2001ce026e4c5f80cc21c81651ff9980be059236c45e215162769ceda266eb46aa4199000e377c0bb53dec98fa1b7c5290459c412f21329b3589a5
DIST bashdb-4.4-1.0.0.tar.bz2 701749 BLAKE2B 2fa4bfd21f6c646c6bb1c2439dfed870478fb985dd52c8ba716e08fa0312da9adb0c29396594280bce525bb88f15b7398878c7a9bb2a39c078d4e5f17706c20a SHA512 eae45eb221c662e6bbf86814b861992944fcdef221e1bbc7df6c4fd0197022b82fabf4b7e5d583ba4fff94a0b486f71901d42f9df12a8b6a5f564e9236ad37e5
+DIST bashdb-4.4-1.0.1.tar.bz2 701807 BLAKE2B 8d41a39831ce9466f5fcd205cf84e337ca7d876fddaea8b8c013fe4ac93a143c9f5b5e46bcc8edbb50fe4c77e87bd282ff9a244e41df007897d3b37f732bb0a3 SHA512 306fc5a49490fe04828cd6c64b23302e0f48ba8558780c93d45d9c615206e91dac5d8ff3d0660e50bc3204873131d1296492bccc23119d2f58c990bd3603221c
diff --git a/app-shells/bashdb/bashdb-4.4.1.0.1.ebuild b/app-shells/bashdb/bashdb-4.4.1.0.1.ebuild
new file mode 100644
index 000000000000..2e08dfbbd120
--- /dev/null
+++ b/app-shells/bashdb/bashdb-4.4.1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2
+ test? ( https://dev.gentoo.org/~whissi/dist/bashdb/bashdb-4.4-1.0.0-missing-test-files.tar.xz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if use test ; then
+ einfo "Copying missing files ..."
+ # https://sourceforge.net/p/bashdb/bugs/52/
+ cp -vafn "${WORKDIR}"/missing-files/* "${S}"/test || die
+ fi
+
+ default
+
+ # We don't install this, so don't bother building it. #468044
+ sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match. #591994
+ econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}