summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/esh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/Manifest1
-rw-r--r--app-shells/esh/esh-0.8.5-r2.ebuild52
-rw-r--r--app-shells/esh/metadata.xml7
3 files changed, 60 insertions, 0 deletions
diff --git a/app-shells/esh/Manifest b/app-shells/esh/Manifest
new file mode 100644
index 000000000000..46c2f39e66ea
--- /dev/null
+++ b/app-shells/esh/Manifest
@@ -0,0 +1 @@
+DIST esh-0.8.5.tar.gz 214040 SHA256 8801c8ffacc07240da20425728bd69897fc26f07839e7e8d5ee9059097961744 SHA512 2473cc2418f70533136305f47dfe59bee560206a8b58c080e2113297dd82483e867937bda1b015069a7220552b4d03346a3b71026a24a2795b0b499e355490a0 WHIRLPOOL c75b59102d6b4bfdc64802016b1af96598d541d75efeb5e255a3d61a4245b0980b5e7d83b453f47eb366aab26a832870e6049cf52ad912e68aaf73b577f22114
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r2.ebuild
new file mode 100644
index 000000000000..44f147ea28c7
--- /dev/null
+++ b/app-shells/esh/esh-0.8.5-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+HOMEPAGE="http://slon.ttk.ru/esh/"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ emake clean
+
+ sed -i \
+ -e 's|-g ||' \
+ -e 's|-DMEM_DEBUG ||' \
+ -e 's|^CFLAGS|&+|g' \
+ -e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
+ -e 's:-ltermcap::' \
+ Makefile || die
+}
+
+src_compile() {
+ # For some reason, this tarball has binary files in it for x86.
+ # Make clean so we can rebuild for our arch and optimization.
+
+ use debug && append-flags -DMEM_DEBUG
+
+ emake \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin esh
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*
+}
diff --git a/app-shells/esh/metadata.xml b/app-shells/esh/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-shells/esh/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>