summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-23 16:05:23 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-23 16:06:47 -0700
commitea1c4fcb124dd83e7c9f6a7d44a133f4bf145a73 (patch)
treef70f2576bb05c263c7bfe8234e57a87beb8f543c /app-shells/fzy
parentapp-shells/fzy: bump to 1.0 (diff)
downloadgentoo-ea1c4fcb124dd83e7c9f6a7d44a133f4bf145a73.tar.gz
gentoo-ea1c4fcb124dd83e7c9f6a7d44a133f4bf145a73.tar.bz2
gentoo-ea1c4fcb124dd83e7c9f6a7d44a133f4bf145a73.zip
app-shells/fzy: sync live ebuild
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-shells/fzy')
-rw-r--r--app-shells/fzy/fzy-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-shells/fzy/fzy-9999.ebuild b/app-shells/fzy/fzy-9999.ebuild
index bbf7b6adbe55..ba77064dac01 100644
--- a/app-shells/fzy/fzy-9999.ebuild
+++ b/app-shells/fzy/fzy-9999.ebuild
@@ -3,13 +3,13 @@
EAPI=6
-inherit savedconfig toolchain-funcs
+inherit eutils savedconfig toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/jhawthorn/fzy.git"
else
- SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/jhawthorn/${PN}/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -31,9 +31,14 @@ src_prepare() {
src_install() {
local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
- exeinto /usr/share/fzy
- doexe contrib/fzy-tmux
- doexe contrib/fzy-dvtm
+ dobin contrib/fzy-tmux
+ dobin contrib/fzy-dvtm
einstalldocs
save_config config.h
}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+ optfeature "opening search results in dvtm pane with provided ${EPREFIX}/usr/bin/fzy-dvtm" app-misc/dvtm
+ optfeature "opening search results in tmux pane with provided ${EPREFIX}/usr/bin/fzy-tmux" app-misc/tmux
+}