summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-02-11 00:08:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-11 00:11:27 +0100
commit05b7292e4392abd73086c2e8e631a9dcc043e4a3 (patch)
treec955f2dc45638ba268fa559c873b901e4d53d8c6 /app-shells/gentoo-bashcomp
parentapp-shells/gentoo-bashcomp: clean up old. (diff)
downloadgentoo-05b7292e4392abd73086c2e8e631a9dcc043e4a3.tar.gz
gentoo-05b7292e4392abd73086c2e8e631a9dcc043e4a3.tar.bz2
gentoo-05b7292e4392abd73086c2e8e631a9dcc043e4a3.zip
app-shells/gentoo-bashcomp: version bump.
Bug: https://bugs.gentoo.org/562626 Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/Manifest1
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index a7cc6a323e5a..d4cd85627218 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1 +1,2 @@
DIST gentoo-bashcomp-20180302.tar.bz2 21485 BLAKE2B 887ac5cfa8c6ba431a6aa5f5918b8bdfbe6a1ae9a2e7ac21b3c06ec2062b448d924f928b1372e81749ece6d4aa673bbbaaa364ca744124c842e3819349917169 SHA512 6b4551b078505e6348cb10ca2d67faab4d323a0f0ddefc872145314303d6f95fe31f9706d43d9f20c0139610ce47e4cf70ba7516d911dc4927cfbf5d863bc063
+DIST gentoo-bashcomp-20190211.tar.bz2 21508 BLAKE2B 410994819f62b0bd105ca398c335d76993fd694b8e7f56c761b94fc1e2f6e90f2010f2f2a88febd71ac0c5643fc0e923c60151fbf9411e8a553b5917d6bcd8db SHA512 4b0a5e79f90ee8122fa8d0a7224fee6472b1762a0dda680ea1c0e8d4069760be9b6472e052b1b166a389c0e779816b98715386dbc62a3574e7ad851b2567a070
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild
new file mode 100644
index 000000000000..645f24d76822
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}