summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-10-10 14:51:35 -0400
committerMike Gilbert <floppym@gentoo.org>2019-10-10 14:51:35 -0400
commitd9c8bde42bba32c9b5c09096a039902de6ce9fbe (patch)
treee5a7cb0000d31b378a8d97dca94e6a37acac7d07 /app-shells/ksh
parentxfce-extra/xfdashboard: x86 stable wrt bug #697454 (diff)
downloadgentoo-d9c8bde42bba32c9b5c09096a039902de6ce9fbe.tar.gz
gentoo-d9c8bde42bba32c9b5c09096a039902de6ce9fbe.tar.bz2
gentoo-d9c8bde42bba32c9b5c09096a039902de6ce9fbe.zip
app-shells/ksh: bump to 2020.0.0
Package-Manager: Portage-2.3.76_p10, Repoman-2.3.17_p62 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/Manifest5
-rw-r--r--app-shells/ksh/files/ksh-2020.0.0-ensure-user-set.patch30
-rw-r--r--app-shells/ksh/files/ksh-2020.0.0-skip-api-test.patch36
-rw-r--r--app-shells/ksh/ksh-2020.0.0.ebuild (renamed from app-shells/ksh/ksh-2020.0.0_beta1.ebuild)17
-rw-r--r--app-shells/ksh/ksh-2020.0.0_alpha1.ebuild33
5 files changed, 84 insertions, 37 deletions
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index b16fc0418a84..13f85b68cedb 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,4 +1 @@
-DIST ksh-2020.0.0-alpha1-conftab.patch 118773 BLAKE2B 63466e18a77cb86af80d6f6b4af74e3ac1edbfa735decfcd772633808a4593f6d4b057a99547482d17b22445e68c6d3e2becdf68516f913c73550da718f2abc3 SHA512 b29a70e8e31a259ac5bf556ddcdb5d4742a8dac4d11c06e4b5fc3043012e08b26d136cce8c18e9e8a1fe751044699d2258388d618408b09379732bea89a51765
-DIST ksh-2020.0.0-alpha1-solaris.patch 12317 BLAKE2B 90681bde2f3bad0e097a9367ea5a3f1d4c95f70c6e0c872dad769609f97a6332328e21399a3b9ba20f3840b3387a02370831ae4663457728bd8e41b7471c675b SHA512 5a0b818f44a860210e2a7795335d0edec01c61dd5ad04670bb2ca505690ff1b111dbda12d0d15e8b264113d4e7a5a42a49f64c9aba0cff809c2ce3185921acad
-DIST ksh-2020.0.0-alpha1.tar.gz 2041308 BLAKE2B 542f7936b7042485c0279c9b79f2d61f9580f0ae654abf60a8044254ed5fe228fa14d48dc7dd835201c32a9448182ca4cb702aac894a74bf5f92a4b866d1de70 SHA512 56c805bebe963dee7c27ba0357e26957fd8439f42c26f290ab32488ddde99f4b824e403c5dc097194eaf600e7379a010b1be4bf1e70bee76402e84909b38d981
-DIST ksh-2020.0.0-beta1.tar.gz 2022254 BLAKE2B 650ad8ea1140bdbe1fb9fc3e2ecbceedb4605525523584d9ac8a067511ed385f1c83d284c781b31140760500f3de13d1ad8fc695c9c553a3285d5c286a99c7ea SHA512 6f54cdc3c59b44055cc6b670b38ce1685463c841a093a28c5f974dd153eaec3b8924308b353ed7c29a0ec3917ee87cfe57b6cabaca9841633d3599d9c6731330
+DIST ksh-2020.0.0.tar.gz 2022880 BLAKE2B cb952c4febe88a3ccf8fd48f511a30a73bfc812ebf0b7a5fe799470b29ee13ca61004fd34e367d836940a88214da2aa05b7cb96f173a1b8d57c8e644c8c3a2a6 SHA512 7d6da3af341a62718d691ddc52e10bdf3b7290d74f1cd01610093c587af47b6d6d04b74b210eb31f93a3559855a5bc5155f9b188d2f8bb4444042c26bfaf1792
diff --git a/app-shells/ksh/files/ksh-2020.0.0-ensure-user-set.patch b/app-shells/ksh/files/ksh-2020.0.0-ensure-user-set.patch
new file mode 100644
index 000000000000..9f5d70f4d33c
--- /dev/null
+++ b/app-shells/ksh/files/ksh-2020.0.0-ensure-user-set.patch
@@ -0,0 +1,30 @@
+From cb9f6d3498622b46de021a7f4798512d203747e9 Mon Sep 17 00:00:00 2001
+From: Kurtis Rader <krader@skepticism.us>
+Date: Sun, 1 Sep 2019 15:44:40 -0700
+Subject: [PATCH] Ensure USER is set when unit tests run
+
+Related #1391
+---
+ src/cmd/ksh93/tests/util/run_test.sh | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/src/cmd/ksh93/tests/util/run_test.sh b/src/cmd/ksh93/tests/util/run_test.sh
+index 20d24ed1fda..ebc74770cae 100644
+--- a/src/cmd/ksh93/tests/util/run_test.sh
++++ b/src/cmd/ksh93/tests/util/run_test.sh
+@@ -62,6 +62,15 @@ fi
+ #
+ export OS_NAME=$(uname -s | tr '[A-Z]' '[a-z]')
+
++#
++# Make sure $USER is set. A CI/CB environment might not set it.
++# See https://github.com/att/ast/issues/1391
++#
++if [[ -z $USER ]]
++then
++ export USER=$(id -un)
++fi
++
+ # TODO: Enable the `io` test on Travis macOS once we understand why it dies from an abort().
+ # I'm not seeing that failure happen on either of my macOS 10.12 or 10.13 systems.
+ if [[ $test_name == io && $OS_NAME == darwin && $CI == true ]]
diff --git a/app-shells/ksh/files/ksh-2020.0.0-skip-api-test.patch b/app-shells/ksh/files/ksh-2020.0.0-skip-api-test.patch
new file mode 100644
index 000000000000..f832d175454e
--- /dev/null
+++ b/app-shells/ksh/files/ksh-2020.0.0-skip-api-test.patch
@@ -0,0 +1,36 @@
+From d89753b5d38482f4a3f17ba3b7d09ab07cfe7419 Mon Sep 17 00:00:00 2001
+From: Kurtis Rader <krader@skepticism.us>
+Date: Sun, 1 Sep 2019 13:47:40 -0700
+Subject: [PATCH] Skip API test if build type != debug
+
+Fixes #1390
+---
+ src/lib/libast/tests/misc/meson.build | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/lib/libast/tests/misc/meson.build b/src/lib/libast/tests/misc/meson.build
+index 67a178762fa..a4c864428d8 100644
+--- a/src/lib/libast/tests/misc/meson.build
++++ b/src/lib/libast/tests/misc/meson.build
+@@ -10,6 +10,12 @@ tests_to_skip = [
+ ['freebsd', 'debug'],
+ ]
+
++# Non-debug build types affect the behavior of `backtrace()`. Which means it will almost certainly
++# break the "debug" test. See https://github.com/att/ast/issues/1390.
++if get_option('buildtype') != 'debug'
++ tests_to_skip += [['*', 'debug']]
++endif
++
+ foreach test_name: tests
+ # If the platform doesn't have an execinfo.h header there is no point in trying to run the
+ # debug.c unit test.
+@@ -18,7 +24,7 @@ foreach test_name: tests
+ endif
+ skip_test = false
+ foreach skip : tests_to_skip
+- if system == skip[0] and test_name == skip[1]
++ if ('*' == skip[0] or system == skip[0]) and test_name == skip[1]
+ warning('skipping ' + test_name + ' on ' + system)
+ skip_test = true
+ # break # Not until meson 0.49
diff --git a/app-shells/ksh/ksh-2020.0.0_beta1.ebuild b/app-shells/ksh/ksh-2020.0.0.ebuild
index 2ccad3528bf3..c2f9bb7797eb 100644
--- a/app-shells/ksh/ksh-2020.0.0_beta1.ebuild
+++ b/app-shells/ksh/ksh-2020.0.0.ebuild
@@ -24,6 +24,23 @@ SLOT="0"
RDEPEND="!app-shells/pdksh"
+PATCHES=(
+ "${FILESDIR}"/ksh-2020.0.0-ensure-user-set.patch
+ "${FILESDIR}"/ksh-2020.0.0-skip-api-test.patch
+)
+
+src_test() {
+ local cmd=(
+ meson test
+ -C "${BUILD_DIR}"
+ --num-processes "$(makeopts_jobs ${NINJAOPTS:-${MAKEOPTS}})"
+ )
+
+ echo "${cmd[@]}" >&2
+ # https://github.com/att/ast/issues/1392
+ env -u T "${cmd[@]}" || die
+}
+
src_install() {
meson_src_install
dodir /bin
diff --git a/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild b/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
deleted file mode 100644
index 3c91825f17c5..000000000000
--- a/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
-HOMEPAGE="https://github.com/att/ast"
-
-MY_PV="${PV/_/-}"
-MY_P="${PN}-${MY_PV}"
-SRC_URI="https://github.com/att/ast/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://github.com/att/ast/commit/db7fe39b744d071bb0428c91e2eb84877f068dac.patch -> ${MY_P}-solaris.patch
- https://github.com/att/ast/commit/63e9edcb6084d4b164439065e2d71f3e900ec3c7.patch -> ${MY_P}-conftab.patch"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="CPL-1.0 EPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="!app-shells/pdksh"
-
-PATCHES=(
- "${DISTDIR}"/${MY_P}-solaris.patch
- "${DISTDIR}"/${MY_P}-conftab.patch
-)
-
-src_install() {
- meson_src_install
- dodir /bin
- mv "${ED}/usr/bin/ksh" "${ED}/bin/ksh" || die
-}