summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-07 00:31:34 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-07 00:31:34 +0100
commit1f563a6ce1f1fe3df73819e66b074d4224667138 (patch)
tree9b7aa1f7b2604fe1d88cd110f48ec7e7ba841be9 /app-shells/mksh/mksh-52c.ebuild
parentsci-mathematics/calc: Add subslot dependency (diff)
downloadgentoo-1f563a6ce1f1fe3df73819e66b074d4224667138.tar.gz
gentoo-1f563a6ce1f1fe3df73819e66b074d4224667138.tar.bz2
gentoo-1f563a6ce1f1fe3df73819e66b074d4224667138.zip
app-shells/mksh: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-shells/mksh/mksh-52c.ebuild')
-rw-r--r--app-shells/mksh/mksh-52c.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/mksh/mksh-52c.ebuild b/app-shells/mksh/mksh-52c.ebuild
new file mode 100644
index 000000000000..e2df980dbb41
--- /dev/null
+++ b/app-shells/mksh/mksh-52c.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MirBSD KSH Shell"
+HOMEPAGE="http://mirbsd.de/mksh"
+SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static"
+DEPEND="static? ( dev-libs/klibc )"
+RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ tc-export CC
+ # we want to build static with klibc
+ if use static ; then
+ unset CC
+ export CC="/usr/bin/klcc"
+ export LDSTATIC="-static"
+ fi
+ export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
+ # we can't assume lto existing/enabled, so we add a fallback
+ sh Build.sh -r -c lto || sh Build.sh -r || die
+}
+
+src_install() {
+ exeinto /bin
+ doexe mksh
+ doman mksh.1
+ dodoc dot.mkshrc
+}
+
+src_test() {
+ ./test.sh || die
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/mksh$" "${ROOT}"etc/shells; echo "/bin/mksh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}