summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-01-19 21:13:25 +0300
committerDavid Seifert <soap@gentoo.org>2017-01-20 20:34:10 +0100
commite925adac9648e5279bf198b6221507a28497f27f (patch)
treea4d21514b03c6eab37e682c7bff228d33f1faa22 /app-shells/mpv-bash-completion
parentnet-libs/nghttp2: add missing net-dns/c-ares dep with USE=utils #604708 (diff)
downloadgentoo-e925adac9648e5279bf198b6221507a28497f27f.tar.gz
gentoo-e925adac9648e5279bf198b6221507a28497f27f.tar.bz2
gentoo-e925adac9648e5279bf198b6221507a28497f27f.zip
app-shells/mpv-bash-completion: verbump to 3.3.8
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3544
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.8.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index 0bb3de7ab111..55a8d0e40185 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1 +1,2 @@
DIST mpv-bash-completion-3.3.7.tar.gz 18986 SHA256 8eb7f516539b0a1b9221088ba0e6676bda63746432ce1c7ec7a2dd91c3dff766 SHA512 927aae0a720c562046cdeda6cedd1dccda45c27789a421e538039c3e1f99d4dc6825a87b1d4493ca9508f32a7b810ff47a7f65e61ef4e53da1aae4ecfe3a5d8d WHIRLPOOL 9fdf1c857243f6b965f95fe7f4e9cd835808f95b05a8d07c23469d6af06eb5f589b19a4d8685fcb2ef0bdf1386540e3a1b7f106808668a91b2e7c90eeb4da120
+DIST mpv-bash-completion-3.3.8.tar.gz 19002 SHA256 67bb3565daafb1e3f64b24262b0859f7843ac052960e0159e3fe3a375ffed181 SHA512 4d6cfc3ac2d1fd6a28be1a40e3ca28d61f5d9ed40a850c5c60e45501b958b929d6ef9266027d2be95ed0c2b0dedccfdbb04fe4115bb7bcfd39435cb73f2dc452 WHIRLPOOL 62012925d3fb212c473e889930c1add93ce36533313a677cc9ddbc7acce2d9dfc1a18f9054dad901f7a0cb2b57c56a05f302f1fadc83b4bbeda5baa06fb2c7c8
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.8.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.8.ebuild
new file mode 100644
index 000000000000..c0ab8a668fc3
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.14.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}