summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/shish/shish-0.7_pre3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/shish/shish-0.7_pre3-r1.ebuild')
-rw-r--r--app-shells/shish/shish-0.7_pre3-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-shells/shish/shish-0.7_pre3-r1.ebuild b/app-shells/shish/shish-0.7_pre3-r1.ebuild
new file mode 100644
index 000000000000..89e2c582668c
--- /dev/null
+++ b/app-shells/shish/shish-0.7_pre3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="The diet shell"
+HOMEPAGE="http://www.blah.ch/shish/"
+SRC_URI="http://www.blah.ch/${PN}/pkg/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug diet"
+
+DEPEND="diet? ( dev-libs/dietlibc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+pkg_setup() {
+ use diet && export CC="diet $(tc-getCC) -nostdinc"
+}
+
+src_prepare() {
+ # Respect CFLAGS, bug #439974
+ sed -i \
+ -e '/CFLAGS="$CFLAGS/d' \
+ -e '/-fexpensive-optimizations -fomit-frame-pointer/d' \
+ configure || die 'sed on configure failed'
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-quiet # bug 439974
+}
+
+src_compile() {
+ # parallel make is b0rked
+ emake -j1
+}
+
+src_install() {
+ default
+ doman doc/man/shish.1
+}
+
+pkg_postinst() {
+ einfo "Updating ${ROOT}etc/shells"
+ ( grep -v "^/bin/shish$" "${ROOT}"etc/shells; echo "/bin/shish" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+}