summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2020-06-15 09:00:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 22:30:50 +0200
commit9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5 (patch)
tree67c3aa0c56dd98ff01e366e17f148dcb9ebde1fc /app-shells/zsh-completions
parentnet-misc/rclone-1.52.1 version bump (diff)
downloadgentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.tar.gz
gentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.tar.bz2
gentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.zip
app-shells/zsh-completions: Bump to 0.32.0
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/16249 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.32.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 6e614985af85..0a7a04a9536a 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1 +1,2 @@
DIST zsh-completions-0.31.0.tar.gz 247806 BLAKE2B 1923013feab9800f2dd0eef7b2263b0e252dd35b21d865e3f42f7946eeba2d1a882179e05fd16fdf473006646896ef87ca1da5cbc9bf69b52c66bcf99e82c010 SHA512 3f707e96c5d08103359304905cd36889d2b8dae82f0ea3781048a8fbd2f1db509abc1a181dc75215552214a59ee532d207897167fdb3850a5b1cc40e13b2b108
+DIST zsh-completions-0.32.0.tar.gz 273885 BLAKE2B 73400a13543f63c45fd32d78752f0294e3eaef9a63d41700aa004e445f123673c8bd8cba7aa3c0969fee0e188ea019b3f92cae2a6de341bf9b2f0f5842792785 SHA512 f1ef5dab3343675a9d82f6df0db4f541196d1904386becc94753b69a4515229ddcc133fe491c33e4a736ea0789c667f50306e60fbe5e61b97d0b3fd4946bf69a
diff --git a/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild
new file mode 100644
index 000000000000..bac7cbeb28ce
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}