summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlaf Torvaldsson <consus@ftml.net>2020-08-03 22:26:21 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-12 10:22:54 +0300
commit15e934f052d022bf88b437e3d8f32f027dd92e44 (patch)
tree981dfc837fcdee8116170f98929dd1677b58686e /app-shells
parentsys-firmware/midisport-firmware: Midisport 8x8 Udev Rule (diff)
downloadgentoo-15e934f052d022bf88b437e3d8f32f027dd92e44.tar.gz
gentoo-15e934f052d022bf88b437e3d8f32f027dd92e44.tar.bz2
gentoo-15e934f052d022bf88b437e3d8f32f027dd92e44.zip
app-shells/fzf: bump to 0.22.0
Signed-off-by: Olaf Torvaldsson <consus@ftml.net> Closes: https://github.com/gentoo/gentoo/pull/16986 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest1
-rw-r--r--app-shells/fzf/fzf-0.22.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 7bc9ed0f9f98..fcf096d3ab90 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -1,5 +1,6 @@
DIST fzf-0.21.0.tar.gz 161819 BLAKE2B 2da6b62425e88c10fa8d3ce3b7d2d25c67a9bd99bf3c402a8e0c84e567f931393fb914e365d0840d4a21409b06b6c76b7f622b68fe99fa5edd9fba8817eefea7 SHA512 8c3b7eb14ac98b386c26bd6621c54a27e904985f2e87c37ae8f31c3596196f32a817be17aa5e7dd399757cb90b5f25c35ce4a240453eb28f7d1d2fd837d8900d
DIST fzf-0.21.1.tar.gz 163978 BLAKE2B 2f05379049229ca01570b3a58bbcaeab48f85330a556efccca2a19b6fbc80da160dd6cada27d35c3fbac3983e71141f408069e70916663aa3b5f40ed5ad22165 SHA512 db816446a2d562148f7bfe4fc99696e0786d4acfe021ba9bf31344c81219b8a61cae03ec7d4b279ab3dba9ca93fc883e655fc71a750fb6f1905612db071ac831
+DIST fzf-0.22.0.tar.gz 168483 BLAKE2B 0be859b9b5b0f4990273e1254b2530f0d651ea612af12a690c570b0fcfbdc23e3b1df8356aaa6bc3d9d042c3cf6c87fc35efe6becdc992bdbcb1b94695961b42 SHA512 003b187c93f0ab2e8a1adbd4eb9586e05e12fb9a86e445ac8ff48ba391ae16f104d60d18934bb46765537d5007035f549c15d6970c901f72813d55001d3bc6e5
DIST github.com%2F!d!a!t!a-!d!o!g%2Fgo-sqlmock%2F@v%2Fv1.3.3.mod 38 BLAKE2B eb94b6f6f4bf332f916cb642fae50486c6ad9f6a7aa1bb57aade3ed640bc98236ae167d30c140c106cee0ada737eca6bdf54d36bcab0751a940f283f55f08c5c SHA512 43bc64732c4ca2ff23bb09cd67f002b05a1b68963116fb42cf9bd60ac8dade8b2efa1cab798217a73b221ea86fb4e219e36912ffe338c7bd505f2a877be05c09
DIST github.com%2Fgdamore%2Fencoding%2F@v%2Fv1.0.0.mod 77 BLAKE2B 1b81c4c20a890027242b50f1566f4dfdaf120ee26d3dc56d0c2b6465df2ba79b208289eb40c3d7b666a4e7e874210f59aea545d5125c9a55c5597a3ca7f37feb SHA512 fb153c4e481c073133f0c933c67eba8a1f160ab146921f2c77125b6ff5c348cea57e3a5701a557c8db2212d32e3cba1c09b9509210660c17b66c2a45ba97cb75
DIST github.com%2Fgdamore%2Fencoding%2F@v%2Fv1.0.0.zip 19867 BLAKE2B a772206ce6dc48b32d7125a25b26694325d367ebcbad85466b2e6cfdb9fc9f0e08b98b7ecede5397344e5f7e623c4c76edcf69dcee99917adccf5b31aad80bf8 SHA512 127767c725e376b43fe4e2003ddc12fe89693d6d7e52b01e6d47d73fd04496decc0fd60b64c7a65303428e00a52ece1848610ea35231789a814187ef8503bee3
diff --git a/app-shells/fzf/fzf-0.22.0.ebuild b/app-shells/fzf/fzf-0.22.0.ebuild
new file mode 100644
index 000000000000..ede17a3ea609
--- /dev/null
+++ b/app-shells/fzf/fzf-0.22.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A general-purpose command-line fuzzy finder, written in GoLang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+EGO_SUM=(
+ "github.com/DATA-DOG/go-sqlmock v1.3.3/go.mod"
+ "github.com/gdamore/encoding v1.0.0"
+ "github.com/gdamore/encoding v1.0.0/go.mod"
+ "github.com/gdamore/tcell v1.3.0"
+ "github.com/gdamore/tcell v1.3.0/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.2"
+ "github.com/lucasb-eyer/go-colorful v1.0.2/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.3"
+ "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.4"
+ "github.com/mattn/go-runewidth v0.0.4/go.mod"
+ "github.com/mattn/go-runewidth v0.0.8"
+ "github.com/mattn/go-runewidth v0.0.8/go.mod"
+ "github.com/mattn/go-shellwords v1.0.9"
+ "github.com/mattn/go-shellwords v1.0.9/go.mod"
+ "github.com/saracen/walker v0.0.0-20191201085201-324a081bae7e"
+ "github.com/saracen/walker v0.0.0-20191201085201-324a081bae7e/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20200128174031-69ecbb4d6d5d"
+ "golang.org/x/crypto v0.0.0-20200128174031-69ecbb4d6d5d/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20190620200207-3b0461eec859"
+ "golang.org/x/net v0.0.0-20190620200207-3b0461eec859/go.mod"
+ "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200202164722-d101bd2416d5"
+ "golang.org/x/sys v0.0.0-20200202164722-d101bd2416d5/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.2"
+ "golang.org/x/text v0.3.2/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "golang.org/x/tools v0.0.0-20191011211836-4c025a95b26e"
+ "golang.org/x/tools v0.0.0-20191011211836-4c025a95b26e/go.mod"
+ "golang.org/x/xerrors v0.0.0-20190717185122-a985d3407aa7/go.mod"
+)
+go-module_set_globals
+
+EGO_PN="github.com/junegunn/${PN}"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ default
+
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from /usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source /usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Or create a symlink:"
+ elog
+ elog " # ln -s /usr/share/fzf/key-bindings.bash /etc/bash/bashrc.d/fzf.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}