summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukáš Poláček <lukas@ksp.sk>2015-09-13 12:07:40 +0200
committerLukáš Poláček <lukas@ksp.sk>2015-09-13 12:07:40 +0200
commit3c5fbd4b17df82fd7ad99d88dbd0491dc9d463ca (patch)
treeca0e806d86f5ff2c1aa36b3e23363c72e777592e /app-shells
parentapp-shells/autojump: remove 22.2.4 (diff)
downloadgentoo-3c5fbd4b17df82fd7ad99d88dbd0491dc9d463ca.tar.gz
gentoo-3c5fbd4b17df82fd7ad99d88dbd0491dc9d463ca.tar.bz2
gentoo-3c5fbd4b17df82fd7ad99d88dbd0491dc9d463ca.zip
app-shells/autojump: use newbashcomp
Also edit autojump.sh to use /usr/share instead of /usr/local/share
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/autojump-22.2.4-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-shells/autojump/autojump-22.2.4-r2.ebuild b/app-shells/autojump/autojump-22.2.4-r2.ebuild
index 6ae3def36b68..b485a21dcc39 100644
--- a/app-shells/autojump/autojump-22.2.4-r2.ebuild
+++ b/app-shells/autojump/autojump-22.2.4-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit python-r1 vcs-snapshot
+inherit bash-completion-r1 python-r1 vcs-snapshot
DESCRIPTION="change directory command that learns"
HOMEPAGE="https://github.com/joelthelion/autojump"
@@ -24,6 +24,7 @@ DEPEND="test? ( dev-python/flake8 dev-python/tox )"
src_prepare() {
sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
-i bin/autojump.sh || die
}
@@ -37,8 +38,8 @@ src_install() {
insinto /etc/profile.d
doins bin/${PN}.sh
+ newbashcomp bin/${PN}.bash ${PN}
insinto /usr/share/"${PN}"/
- doins bin/${PN}.bash
doins bin/${PN}.zsh
insinto /usr/share/zsh/site-functions
doins bin/_j