summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBláithín Nic Aoidh <blawheen@gmail.com>2017-02-04 01:29:29 +0000
committerPatrice Clement <monsieurp@gentoo.org>2017-02-09 00:36:55 +0100
commit6067333c0add185321283acfba2664ca6d69bea1 (patch)
tree2a1f270e70283b91ac8e5b319980c41c3353fcaf /app-shells
parentapp-shells/hstr: remove unused patch files. (diff)
downloadgentoo-6067333c0add185321283acfba2664ca6d69bea1.tar.gz
gentoo-6067333c0add185321283acfba2664ca6d69bea1.tar.bz2
gentoo-6067333c0add185321283acfba2664ca6d69bea1.zip
app-shells/hstr-1.22: version bump.
Closes: https://github.com/gentoo/gentoo/pull/3795
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/hstr/Manifest1
-rw-r--r--app-shells/hstr/hstr-1.22.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index d3db61fe0d32..fd1351436c26 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1 +1,2 @@
DIST hstr-1.21.tar.gz 45851 SHA256 f0e9762f2a9587f0995bbd51cb64526ae852c2425ceb8ceee0747efba80ac6b3 SHA512 dbcb8766ca7f5ca2265f30726c451b9fe9a51d9dc7a08293fae1e9eb5cb2f562a5a9fa96fa90bd703ae3db0446628c884349c636060fbebd97bd7413a5c6e4d0 WHIRLPOOL 33cc21efe738efe7dd2bccf7c7fc7b79e6b0fb9bca0d458232a44695a0c422aa6184962ea69964e5b8e22a73aa7c54dc859dbb9666ab8b0e48abfeb6d8c72afd
+DIST hstr-1.22.tar.gz 46487 SHA256 c4995e7041dc66e2118f83bd4c6c7f4cff5b4c493ca28bd7e4aef76edeff71ba SHA512 5f31434410963c236f4e0d1117f09849b0a391d4173924d9eb2b2ddb9977a8bcb5a0c9b2e01045b618d01dfbcebd9c5db41534cb6abbb024a3515d5994b442cd WHIRLPOOL 30c6e42c91eebbcf55d6e8d89921d0760e3bda8e84ece0e2ccc7ef6be51dae15806f3db434b79a3afa4e8a9ebe63462fa927cc305c7a8d89a5d0651aa342493e
diff --git a/app-shells/hstr/hstr-1.22.ebuild b/app-shells/hstr/hstr-1.22.ebuild
new file mode 100644
index 000000000000..e6d461524b8d
--- /dev/null
+++ b/app-shells/hstr/hstr-1.22.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}