summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-03-27 01:17:27 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-03-31 00:26:15 +0200
commit6743e44892d2ff6278d18f08d821d93d7c846595 (patch)
tree7164e00bcd90ca5bbfefb6c87ff49b86560358c9 /app-shells
parentnet-analyzer/nagios-plugins: new version 2.2.0. (diff)
downloadgentoo-6743e44892d2ff6278d18f08d821d93d7c846595.tar.gz
gentoo-6743e44892d2ff6278d18f08d821d93d7c846595.tar.bz2
gentoo-6743e44892d2ff6278d18f08d821d93d7c846595.zip
app-shells/mpv-bash-completion: verbump to 3.3.11.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.11.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index cf92340a02ce..7e422bbad155 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-3.3.10.tar.gz 19113 SHA256 ead8c528b9e3862063499f241560d63e9b0786f770d666e92eeb0a371c172baf SHA512 0344b5dca82af57bf32e142bd70229067079eed1f152a0803c764f63c39dabbf6b283f3624b87f863b02c6dd3fac77010ef014523b835d0f1a24f4fd4ff22e0d WHIRLPOOL 926f23ef86a11c169d881d480354632bf723a6e7160e8f922c8a8fca96aa1012ff356c87a0f529020bac3c09233ad73693e96b03a2e7f1c91b59855e3a9e616a
+DIST mpv-bash-completion-3.3.11.tar.gz 19225 SHA256 b74a180c3318bafc9e8d240bb90f2de1f26a653776abd18f6f7c188fe8a38626 SHA512 ac0244c048c7d468fb6f971e58c631c39c919be9a049bb600abed9df9b2ae1429aba918714f6ad60b3cec48bf4dbcf81673946bc5736c0deb0d57585af460f21 WHIRLPOOL 1e25ffb8baba95381463d9ddd1b6ca18d8e954470fa8a384d00645049978869bc00408e7596fe0878c6a6a7e8fe8cf5567ad47a71a1f69945ca469dc560aa799
DIST mpv-bash-completion-3.3.8.tar.gz 19002 SHA256 67bb3565daafb1e3f64b24262b0859f7843ac052960e0159e3fe3a375ffed181 SHA512 4d6cfc3ac2d1fd6a28be1a40e3ca28d61f5d9ed40a850c5c60e45501b958b929d6ef9266027d2be95ed0c2b0dedccfdbb04fe4115bb7bcfd39435cb73f2dc452 WHIRLPOOL 62012925d3fb212c473e889930c1add93ce36533313a677cc9ddbc7acce2d9dfc1a18f9054dad901f7a0cb2b57c56a05f302f1fadc83b4bbeda5baa06fb2c7c8
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.11.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.11.ebuild
new file mode 100644
index 000000000000..dc4633a3b92d
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.14.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}