summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-28 07:35:13 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-28 10:23:04 +0200
commitacb260f67098ce79cdcdc6f26c6aaf33182abef2 (patch)
treead9c946d55b38b09ecd8017834b5e8c6a6d04f64 /app-shells
parentapp-crypt/eid-mw: update live ebuild. Vincent Hardy (diff)
downloadgentoo-acb260f67098ce79cdcdc6f26c6aaf33182abef2.tar.gz
gentoo-acb260f67098ce79cdcdc6f26c6aaf33182abef2.tar.bz2
gentoo-acb260f67098ce79cdcdc6f26c6aaf33182abef2.zip
app-shells/bash-completion: Bump to 2.6
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/Manifest1
-rw-r--r--app-shells/bash-completion/bash-completion-2.6.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 9927439a1e0a..e00876b31ee5 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -2,5 +2,6 @@ DIST bash-completion-2.1_p20141224.tar.xz 257964 SHA256 a76ffdbc9f49f48e290f0e6f
DIST bash-completion-2.3.tar.xz 272252 SHA256 b2e081af317f3da4fff3a332bfdbebeb5514ebc6c2d2a9cf781180acab15e8e9 SHA512 396c060fa39aa05866d26b573d6b9eebdb96e41a17ef723e95f8b01bbda32b0b83bf9e4d978a4f0a1c0590787ae797bb3b6417b95b877f8447037cb873ccf38a WHIRLPOOL fe5ebae1c77dfba504e8f79b130ba0bc80d882a045b980a23f4642e77dfb7bb79b529c1573b13fc0986f486c41696bb94fadef677e0cabfdffe7aeea6e8ff5c0
DIST bash-completion-2.4.tar.xz 276148 SHA256 c0f76b5202fec9ef8ffba82f5605025ca003f27cfd7a85115f838ba5136890f6 SHA512 b852e0a38417dfc3754a91dae2d107f99a3c2970d835a4bbaa80f2a4db8d670bc3820ddc6ada26f68070f22fb4c1db7abe50ad489b1c0f8497b1e6e91be27627 WHIRLPOOL f38f148dcbca1ee47ec6fa33637ea0673c03816b607bd638605832fb76ec7fb5f24cba35cb559e8a5b06636b1ec0f225e420615b6721074fc405cb79b505b07b
DIST bash-completion-2.5.tar.xz 276732 SHA256 b0b9540c65532825eca030f1241731383f89b2b65e80f3492c5dd2f0438c95cf SHA512 44ca2cbf38190c2bfa1e98021c1de36dbef0e55f9fe7840e83bd7f91b4c9afc92afa9bb03d53dbc6d9f9b468ac63ff1021a60e456fc239010010d75687eff3da WHIRLPOOL b488571aca9d8b027214c2964ec789ef616659a098a2bd65a921075d94a8014b51a802040535e44c7831b159a5094b6879935f726ee97409b575c36cd01dbc13
+DIST bash-completion-2.6.tar.xz 279932 SHA256 61fb652da0b1674443c34827263fe2335f9ddb12670bff208fc383a8955ca5ef SHA512 d2eb69595c297fda7e12d645f4b84d419769408d2e4b999cc867b469c8297941c491352bb9096f21fe3502ba03761450629b4dc9fdf451d90fa37c1fa244ab67 WHIRLPOOL b61b4bb0a4685c7166f2836c6ad62ae33d24cbd7018712d35ae47fda34db9f14f8ae7bb0380ff44222eb8c00cbf83138d5088ef465ebdb9d1ff10944653660ec
DIST bashcomp-2.0.1.tar.bz2 4078 SHA256 142348b61b32fb3f1580ac90b684b1014d6d177f371baadb503340c507f9a992 SHA512 8ac8982f418a2d71dffcf027ffe0b7eefa3ee49413a726a8ee9e758975d8f86c687a64b55cd94e09b7936d1c6990285ddc90a3c2b1989af44322937c5c4fb8d7 WHIRLPOOL b6daa0a93282e9df73635cbdddde97c473fd22aa3baf035c3ffcb5966152e20b26d85979fe8a5ecf9128157422f3f60dc27c82c843b9a0e6e80b7de7da596250
DIST bashcomp-2.0.2.tar.gz 3625 SHA256 6ede58bfbe99f0dca1eb9236492aa20a6755e5731526de56e15d1e2b220165c9 SHA512 46bc1bcc32263135f44be68569459a409250dd2c81c18190735f11e13a26508e9d3cb91d24a8fe7b21bdea678347873b7ac1b67d5e8c78c8444011f85dfdcdce WHIRLPOOL 4b6cb989235d5fed8fd9986c1419ab337df38384fe2b307fd78f08f8696f4a2328845ed4f27913a36e9a544e973690bc0dd2af73816e272c3faf27ff2eafa585
diff --git a/app-shells/bash-completion/bash-completion-2.6.ebuild b/app-shells/bash-completion/bash-completion-2.6.ebuild
new file mode 100644
index 000000000000..0585f5e0e970
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.6.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+BASHCOMP_P=bashcomp-2.0.2
+inherit versionator
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="https://github.com/scop/bash-completion"
+SRC_URI="https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
+ https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.3_p30-r1
+ sys-apps/miscfiles
+ !app-eselect/eselect-bashcomp"
+DEPEND="app-arch/xz-utils"
+PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+
+# Remove unwanted completions.
+STRIP_COMPLETIONS=(
+ # Slackware package stuff, quite generic names cause collisions
+ # (e.g. with sys-apps/pacman)
+ explodepkg installpkg makepkg pkgtool removepkg upgradepkg
+
+ # Debian/Red Hat network stuff
+ ifdown ifup ifstatus
+
+ # Installed in app-editors/vim-core
+ xxd
+
+ # Now-dead symlinks to deprecated completions
+ hd ncal
+
+ # Installed by sys-apps/util-linux-2.28
+ mount umount mount.linux umount.linux
+)
+
+src_prepare() {
+ eapply "${WORKDIR}/${BASHCOMP_P}/${PN}"-2.1_p*.patch
+ # Bug 543100, update bug 601194
+ eapply "${FILESDIR}/${PN}-2.1-escape-characters-r1.patch"
+ eapply_user
+}
+
+src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
+
+src_install() {
+ # work-around race conditions, bug #526996
+ mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
+
+ emake DESTDIR="${D}" profiledir="${EPREFIX}"/etc/bash/bashrc.d install
+
+ local file
+ for file in "${STRIP_COMPLETIONS[@]}"; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ done
+ # remove deprecated completions (moved to other packages)
+ rm "${ED}"/usr/share/bash-completion/completions/_* || die
+
+ dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
+
+ # install the eselect module
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
+ doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.1-r90 ${v}; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ ewarn
+ ewarn "After the rebuild, you should remove the old setup symlinks:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}