summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2020-01-19 15:56:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-18 10:49:06 +0200
commitf8be7774fbb089dbeae3352c15a79a261740adf3 (patch)
treea6b496e626c659a0f0ed189f9256e1d1113f2f5c /app-text/asciidoc
parentnet-misc/dhcp: Revbump to remove old user eclass remnants (diff)
downloadgentoo-f8be7774fbb089dbeae3352c15a79a261740adf3.tar.gz
gentoo-f8be7774fbb089dbeae3352c15a79a261740adf3.tar.bz2
gentoo-f8be7774fbb089dbeae3352c15a79a261740adf3.zip
app-text/asciidoc: 9.0.0_rc1 version bump
Note that since reference outputs are now included in the source distribution, it doesn't make sense anymore to update the test data outputs. - Fix the test deps by adding a dependency on app-text/dvisvgm. This did not cause test failures, but did cause "command not found" type errors. - List documentation in $DOCS instead of calling dodocs manually. - Consistently put $PYTHON_DEPS at the top of the dependency lists. - Constrain the dev-libs/libxml2 dependency to slot 2. - Instead of controlling optional runtime deps with USE flags, use "optfeature" from the eutils eclass. While at it, add further calls to optfeature for hitherto only indirectly documented optional dependencies. Signed-off-by: Marc Joliet <marcec@gmx.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 2cc64555678e..9821a9f8b5f2 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1 +1,2 @@
DIST asciidoc-8.6.10_p20181016.tar.gz 576694 BLAKE2B 4d255606675346d00ab03398bf48cb30d357f9f9366944e4faf66ae4c96dafce49acdd930fc848f3dbb2d704a004bb5815d17b53416a76c8368a92e4716328b2 SHA512 801f360b0c444e932f1c50897d446de0ec3f0fb2206080b5aa6dda396fede96065f7bb629a84c8a8e40c5d8897f305fdb1877512f04ae757f3b142fd3a7305d0
+DIST asciidoc-9.0.0_rc1.tar.gz 1143528 BLAKE2B 97e2ee77cf7554e2e0d53e792213377e6cb233853717487b0c0ac1c70d233a5d58a08f3aa69ae840c90f98185b595f9feb7396795b2de47ff0cfc0147920bc2a SHA512 965d65df18ff90596e5cd72bec8d0f7daf2f6ad585ec77af2a6ae9637569b613e2384cc7015c1823fcde99be8170107789505a543fe8b6d3273f2c75a6a92960
diff --git a/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild b/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild
new file mode 100644
index 000000000000..dd4f5537e218
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
+
+inherit autotools eutils python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="http://asciidoc.org/ https://github.com/asciidoc/asciidoc-py3/"
+SRC_URI="https://github.com/${PN}/${PN}-py3/archive/9.0.0rc1.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+ "
+DEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ app-text/dvisvgm
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick
+ media-sound/lilypond
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
+ docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
+ filters/code/code-filter-readme.txt )
+
+S="${WORKDIR}/${PN}-py3-9.0.0rc1"
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_test() {
+ local -x ASCIIDOC_PY=asciidoc.py
+ "${EPYTHON}" tests/test${PN}.py run || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+
+ # Below results in some files being installed twice in different locations, but they are
+ # in the right place, uncompressed, and there won't be any broken links. See bug #483336
+ if use examples; then
+ # examples/website is full of relative symlinks,
+ # deref them for copying, which dodoc doesn't do
+ cp -rL examples/website "${ED}"/usr/share/doc/${PF}/examples || die
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
+ optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments[${PYTHON_USEDEP}] app-text/highlight
+ optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "\"graphviz\" filter support" media-gfx/graphviz
+}