summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/csvfix/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/csvfix/files')
-rw-r--r--app-text/csvfix/files/csvfix-1.10a-tests.patch51
-rw-r--r--app-text/csvfix/files/csvfix-1.3-make.patch61
-rw-r--r--app-text/csvfix/files/csvfix-1.6-makefile.patch69
3 files changed, 181 insertions, 0 deletions
diff --git a/app-text/csvfix/files/csvfix-1.10a-tests.patch b/app-text/csvfix/files/csvfix-1.10a-tests.patch
new file mode 100644
index 000000000000..8e4461d85a31
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.10a-tests.patch
@@ -0,0 +1,51 @@
+--- csvfix-build.orig/csvfix/tests/run1
++++ csvfix-build/csvfix/tests/run1
+@@ -1,4 +1,4 @@
+-#!bash
++#!/bin/bash
+ # run1
+ # run single test
+ # copyright (C) 2008 Neil Butterworth
+@@ -49,7 +49,7 @@
+ fi
+
+ # exe to be tested - used in tests
+-CSVED=../bin/csvfix.exe
++CSVED=../bin/csvfix
+ export CSVED
+
+ if [ ! -f "$CSVED" ]
+@@ -64,7 +64,7 @@
+ fi
+
+ # where to find diff & where to put output
+-DIFF=/bin/diff
++DIFF=/usr/bin/diff
+ DIFFOUT=tmp/_diffout
+ WINDIFF="C:/Program Files/Microsoft Visual Studio/Common/Tools/WINDIFF.EXE"
+ TEST=`basename $TEST`
+@@ -133,5 +133,7 @@
+ fi
+ else
+ echo "Execution problem with $TEST - please correct"
++ color_red "FAILED $TEST"
++ exit 1
+ fi
+
+--- csvfix-build.orig/csvfix/tests/runtests
++++ csvfix-build/csvfix/tests/runtests
+@@ -1,4 +1,4 @@
+-#!bash
++#!/bin/bash
+ # runall.bash
+ # run all tests and report
+
+@@ -22,3 +22,8 @@
+ echo $FAILS failed, $PASSES passed
+ echo ""
+
++if [[ $FAILS -gt 0 ]]; then
++ exit 1
++else
++ exit 0
++fi
diff --git a/app-text/csvfix/files/csvfix-1.3-make.patch b/app-text/csvfix/files/csvfix-1.3-make.patch
new file mode 100644
index 000000000000..33ea0732107d
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.3-make.patch
@@ -0,0 +1,61 @@
+--- csvfix-1.3/alib/Makefile
++++ csvfix-1.3/alib/Makefile
+@@ -2,12 +2,12 @@
+ # Copyright (C) 2009 Neil Butterworth
+
+ OUT = lib/alib.a
++AR = ar
+ CC = g++
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ _OBJS = a_chsrc.o a_csv.o a_enc.o a_env.o a_except.o \
+ a_expr.o a_myth.o a_inifile.o a_exec.o \
+@@ -21,9 +21,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -31,10 +28,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+ clean:
+--- csvfix-1.3/csvfix/Makefile
++++ csvfix-1.3/csvfix/Makefile
+@@ -18,7 +18,7 @@
+
+ ALIB = ../alib/lib/alib.a
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_block.o \
+@@ -89,8 +89,7 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS) $(ALIB)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
diff --git a/app-text/csvfix/files/csvfix-1.6-makefile.patch b/app-text/csvfix/files/csvfix-1.6-makefile.patch
new file mode 100644
index 000000000000..aaee2aa003f7
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.6-makefile.patch
@@ -0,0 +1,69 @@
+--- neilb-csvfix-e804a794d175/alib/Makefile
++++ neilb-csvfix-e804a794d175/alib/Makefile
+@@ -2,12 +2,12 @@
+ # Copyright (C) 2009 Neil Butterworth
+
+ OUT = lib/alib.a
++AR = ar
+ CCTYPE = gcc
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ cc.gcc = g++
+ cc.clang = clang++ -std=c++11 -stdlib=libc++
+@@ -26,9 +26,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -36,10 +33,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+ clean:
+--- neilb-csvfix-e804a794d175/csvfix/Makefile
++++ neilb-csvfix-e804a794d175/csvfix/Makefile
+@@ -22,7 +22,7 @@
+
+ ALIB = ../alib/lib/alib.a
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_block.o \
+@@ -99,8 +99,7 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS) $(ALIB)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
+--- neilb-csvfix-e804a794d175/Makefile
++++ neilb-csvfix-e804a794d175/Makefile
+@@ -1,3 +1,5 @@
++CFLAGS += -std=c++11
++
+ ifndef COMSPEC
+ CLEAN = (cd alib; $(MAKE) clean) && (cd csvfix; $(MAKE) clean)
+ else