summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-10 15:32:02 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-10 15:40:44 -0400
commit33dbee938d2a21463781db5d37e8fe60b0a4e7f3 (patch)
tree85fec8b4aef403dc0f4f625ba22e89a7fb75aa67 /app-text/discount
parentnet-analyzer/wireshark: arm stable, bug #589926 (diff)
downloadgentoo-33dbee938d2a21463781db5d37e8fe60b0a4e7f3.tar.gz
gentoo-33dbee938d2a21463781db5d37e8fe60b0a4e7f3.tar.bz2
gentoo-33dbee938d2a21463781db5d37e8fe60b0a4e7f3.zip
app-text/discount: new version 2.2.0.
This new version updates the ebuild to EAPI=6, and drops the eutils/multilib eclasses that are no longer needed. It also removes some obsolete hacks (thanks to an upstream patch by binki), and adds a test suite. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 3eb722a08df6..d731d4f17227 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,2 +1,3 @@
DIST discount-2.1.6.tar.bz2 83823 SHA256 702bb29e17e387f82e40fae062d5e4939bc6fb22dcf53e6109982a5faa110796 SHA512 75e2fcc31f670bab77a3658a684054971998e91ad14743814480a4d24a59285dea1fe922d16c8d1c868250c417963a80282b8fe278021240ba424b840dd4df8e WHIRLPOOL 9f519c44df4bc5300729dd0f51fbcb20f957da68d03b670307bfd51c0d994b5d2b765eac6e17bba8119bb095277ce5dfbad185599bdeca834c4982eb813d7a79
DIST discount-2.1.8a.tar.bz2 85161 SHA256 c01502f4eedba8163dcd30c613ba5ee238a068f75291be127856261727e03526 SHA512 a1eba7076a27da56136b8057189c5474a36bf11f8233cbae270c8a0cf9b070332b4dcdbbbecfbfbe1d8c19961ccaf87cee27ebe855c6bc6558d8ccc423553c96 WHIRLPOOL 5d7148f6c4e9f84a5290fffafa417c4684517df6fce0deec773beb2f89b4416b7849aa50351c27338653b8950b68c3c49ba223d31e347ad7562b0cb040761114
+DIST discount-2.2.0.tar.bz2 88387 SHA256 b25395c29c2c08836199eb2eae87b56e6b545e77f5fbf921678aa1dc0ddab9f3 SHA512 04b66496ca53a2ab73cba2a8f9d8e77efd13f318b188611aaaebc4fd036a02cd188aa712337df414ff3b7ac65d2ced17020085cae10338e8af47e5b9552d981a WHIRLPOOL 1b4f30e924c4f38bc0685eb78c609c461e282dd54c6f588098ffb86dc03330ab45c68340dea5dd965cd26b42771ffc379c9ef828bbfc3a79f593b75f483c3e1d
diff --git a/app-text/discount/discount-2.2.0.ebuild b/app-text/discount/discount-2.2.0.ebuild
new file mode 100644
index 000000000000..b04caa9f06c4
--- /dev/null
+++ b/app-text/discount/discount-2.2.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal test"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,-s ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+
+ # Add LDFLAGS and CPPFLAGS hackily.
+ sed -i \
+ -e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
+ -e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
+ Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}"usr/"$(get_libdir)"
+ --prefix="${EPREFIX}"usr
+ --mandir="${EPREFIX}"usr/share/man
+ --shared
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]} || die"
+ "${configure_call[@]}" || die
+}
+
+src_test() {
+ # I can't get these to pass; might be fixed in the future. The rest
+ # work fine.
+ rm -rf tests/muñoz.t || die 'failed to remove failing tests'
+ default
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}