summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-02 10:44:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-02 10:44:43 +0100
commit383eecae5f3cd37c1baed070fec6a7a3a489d70f (patch)
tree9ddef914afcaebf8476207e1e5b451e19be3b7b7 /app-text/fbpdf
parentdev-ruby/kirbybase: add ruby24; fix test invocation, bug 623462 (diff)
downloadgentoo-383eecae5f3cd37c1baed070fec6a7a3a489d70f.tar.gz
gentoo-383eecae5f3cd37c1baed070fec6a7a3a489d70f.tar.bz2
gentoo-383eecae5f3cd37c1baed070fec6a7a3a489d70f.zip
app-text/fbpdf: fix build failure against app-text/mupdf-1.11, bug #623468
app-text/mupdf 1.11 does not provide mupdfthird library anymore and build fails as: x86_64-pc-linux-gnu-gcc -o fbpdf fbpdf.o mupdf.o draw.o -Wl,-O1 -Wl,--as-needed -lmupdf -lmupdfthird -lcrypto -lm /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lmupdfthird collect2: error: ld returned 1 exit status Now app-text/mupdf provides single 'mupdf' library. Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/623468 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-text/fbpdf')
-rw-r--r--app-text/fbpdf/fbpdf-0_p20161202.ebuild5
-rw-r--r--app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch9
2 files changed, 13 insertions, 1 deletions
diff --git a/app-text/fbpdf/fbpdf-0_p20161202.ebuild b/app-text/fbpdf/fbpdf-0_p20161202.ebuild
index d7cb3668d43f..02e5ea6ffd6a 100644
--- a/app-text/fbpdf/fbpdf-0_p20161202.ebuild
+++ b/app-text/fbpdf/fbpdf-0_p20161202.ebuild
@@ -28,7 +28,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
-PATCHES=("${FILESDIR}"/${P}-format.patch)
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+ "${FILESDIR}"/${P}-mupdfthird.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch b/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch
new file mode 100644
index 000000000000..070b7c72ea26
--- /dev/null
+++ b/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile b/Makefile
+index f986689..374837f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,3 +13,3 @@ clean:
+ fbpdf: fbpdf.o mupdf.o draw.o
+- $(CC) -o $@ $^ $(LDFLAGS) -lmupdf -lmupdfthird -lcrypto -lm
++ $(CC) -o $@ $^ $(LDFLAGS) -lmupdf -lcrypto -lm
+