summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 16:02:23 +0100
committerSam James <sam@gentoo.org>2022-04-17 16:18:33 +0100
commit63016fc25366ccadb8949f56d2f1e85e409db4be (patch)
tree0951e17755f698af795027016e8a2ce09f5a792e /app-text/groonga-normalizer-mysql
parentsci-geosciences/xtide: update EAPI 6 -> 8 (diff)
downloadgentoo-63016fc25366ccadb8949f56d2f1e85e409db4be.tar.gz
gentoo-63016fc25366ccadb8949f56d2f1e85e409db4be.tar.bz2
gentoo-63016fc25366ccadb8949f56d2f1e85e409db4be.zip
app-text/groonga-normalizer-mysql: drop static-libs, EAPI 8
Closes: https://bugs.gentoo.org/793809 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/groonga-normalizer-mysql')
-rw-r--r--app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1-r1.ebuild (renamed from app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild)18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1-r1.ebuild
index 86f8be4f031a..c2a7aacdc072 100644
--- a/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1.ebuild
+++ b/app-text/groonga-normalizer-mysql/groonga-normalizer-mysql-1.1.1-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
@@ -11,20 +12,21 @@ SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="app-text/groonga"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( README.md )
src_prepare() {
- default_src_prepare
+ default
+
eautoreconf
}
src_configure() {
- # ruby is only uses for tests
+ # ruby is only used for tests
econf --without-ruby
}
@@ -32,5 +34,5 @@ src_install() {
default
find "${ED}" -name '*.la' -delete || die
- rm -r "${D}usr/share/doc/${PN}" || die
+ rm -r "${ED}"/usr/share/doc/${PN} || die
}