summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-03 16:32:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-03 16:37:19 +0200
commit13809b3b69e4124527001c959612bf5de18a56c3 (patch)
tree7e8c8738f71af392526ec8f332645deca9f2124e /app-text/kchmviewer/kchmviewer-8.0.ebuild
parentapp-misc/uptimed: remove USE=static-libs (diff)
downloadgentoo-13809b3b69e4124527001c959612bf5de18a56c3.tar.gz
gentoo-13809b3b69e4124527001c959612bf5de18a56c3.tar.bz2
gentoo-13809b3b69e4124527001c959612bf5de18a56c3.zip
app-text/kchmviewer: Re-introduce package at version 8.0
Reported-by: Michael <voron1@gmail.com> Closes: https://bugs.gentoo.org/806214 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/kchmviewer/kchmviewer-8.0.ebuild')
-rw-r--r--app-text/kchmviewer/kchmviewer-8.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/kchmviewer/kchmviewer-8.0.ebuild b/app-text/kchmviewer/kchmviewer-8.0.ebuild
new file mode 100644
index 000000000000..f4e5199ee3cf
--- /dev/null
+++ b/app-text/kchmviewer/kchmviewer-8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Feature rich chm file viewer, based on Qt"
+HOMEPAGE="https://www.ulduzsoft.com/kchmviewer/"
+SRC_URI="https://github.com/gyunaev/${PN}/archive/refs/tags/RELEASE_${PV/./_}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/kchmviewer-RELEASE_8_0"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/chmlib
+ dev-libs/libzip:=
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+ "${FILESDIR}/${P}-custom-url-scheme-registration.patch"
+)
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dodoc ChangeLog DBUS-bindings FAQ README
+ doicon packages/kchmviewer.png
+ dobin bin/kchmviewer
+ domenu packages/kchmviewer.desktop
+}