summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-14 06:31:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-14 19:42:01 +0100
commit6dc964333c20dc2e7ac2e9c1f769afa45726aad2 (patch)
tree30b5900c73ea462a6cbb0a2714bede6463c9e704 /app-text/libetonyek
parentdev-db/postgresql: Stabilize 17.1 arm, #943513 (diff)
downloadgentoo-6dc964333c20dc2e7ac2e9c1f769afa45726aad2.tar.gz
gentoo-6dc964333c20dc2e7ac2e9c1f769afa45726aad2.tar.bz2
gentoo-6dc964333c20dc2e7ac2e9c1f769afa45726aad2.zip
app-text/libetonyek: add 0.1.11
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libetonyek')
-rw-r--r--app-text/libetonyek/Manifest1
-rw-r--r--app-text/libetonyek/libetonyek-0.1.11.ebuild60
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild7
3 files changed, 64 insertions, 4 deletions
diff --git a/app-text/libetonyek/Manifest b/app-text/libetonyek/Manifest
index 710f9294bb53..11dc0cfc143d 100644
--- a/app-text/libetonyek/Manifest
+++ b/app-text/libetonyek/Manifest
@@ -1 +1,2 @@
DIST libetonyek-0.1.10.tar.xz 1494000 BLAKE2B 1c47b410050380d134d96b5551f0c9186c24aa0ea52c801e26655e3013f030e92198d8e3f19e8a341744206eeaad2d10ca130f286fd42c8a9c3b56f773cfa7d5 SHA512 516a14fcb7b7b5898484a4263d593a036ac728b90144da9d1c22a5d0fdffc879839e19a7b390f99d924c390d433e64433fb08939b1e04ca24359315571c5772b
+DIST libetonyek-0.1.11.tar.xz 1513056 BLAKE2B 2c96e85b4c11ae33a858e3b3f6ec3c76aaa9b9a4e798f436ae5a379adc48622ca5f1da1d7a7b29b2dac8dab27c05acc2f98d778c5258432c688534fbcce0eb86 SHA512 b04593062d905340fdc6049d9fcd4524f8f8d8e313041b1ca811c63c08b218398b11a5cd6c3c724659d108c6f15756d5a87c88e85e27b2b5ed846af3b90de2ab
diff --git a/app-text/libetonyek/libetonyek-0.1.11.ebuild b/app-text/libetonyek/libetonyek-0.1.11.ebuild
new file mode 100644
index 000000000000..535cecb7dd54
--- /dev/null
+++ b/app-text/libetonyek/libetonyek-0.1.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library parsing Apple Keynote presentations"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/liblangtag
+ dev-libs/librevenge
+ dev-libs/libxml2
+ >=dev-util/mdds-2.1:1=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glm
+ dev-build/libtool
+ test? ( dev-util/cppunit )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4" || die
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ --with-mdds=2.1
+ $(use_with doc docs)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
+}
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index 874395b30224..975c7f6efb90 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="doc static-libs test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -41,7 +41,7 @@ BDEPEND="
src_prepare() {
default
- [[ -d m4 ]] || mkdir "m4"
+ [[ -d m4 ]] || mkdir "m4" || die
[[ ${PV} == *9999* ]] && eautoreconf
}
@@ -50,7 +50,6 @@ src_configure() {
--disable-werror
--with-mdds="${MDDS_VER}"
$(use_with doc docs)
- $(use_enable static-libs static)
$(use_enable test tests)
)
econf "${myeconfargs[@]}"
@@ -58,5 +57,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -type f -delete || die
}