summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/libspectre
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/Manifest2
-rw-r--r--app-text/libspectre/files/libspectre-0.2.0-interix.patch29
-rw-r--r--app-text/libspectre/libspectre-0.2.6.ebuild51
-rw-r--r--app-text/libspectre/libspectre-0.2.7.ebuild51
-rw-r--r--app-text/libspectre/metadata.xml8
5 files changed, 141 insertions, 0 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
new file mode 100644
index 000000000000..df02906932b3
--- /dev/null
+++ b/app-text/libspectre/Manifest
@@ -0,0 +1,2 @@
+DIST libspectre-0.2.6.tar.gz 358088 SHA256 2f637c62322c8040514284c00f63a5c310a28801e7dcfbe2ba2791be4fac0dd3 SHA512 4f99afe68293e188f70a5043f0c5199123d6ab0936f196b198f1c66eff980d54a6fba093be39839180dcef82db5fd9780a9d50887e453352d7b90b986829dfb6 WHIRLPOOL 0335575a7a5a5fa5724b35456105badcb845202b0d48b03a03f292aab10959e1a4ba9d94189c935667114878f20f7a5b8cbb892bf52533b4846a5afebb1eecb7
+DIST libspectre-0.2.7.tar.gz 387947 SHA256 e81b822a106beed14cf0fec70f1b890c690c2ffa150fa2eee41dc26518a6c3ec SHA512 2e60905f7eeed9ac6ec3b5f8b47a7dad85178c8c35a63ba097ef6088dd334f7fde5797ecb05cf67532b759d07a65006427914d2cd6b09107ecc90620c9541794 WHIRLPOOL b59a1fea4ebd0cac13d4b5c7e76247de214761929bd71cf7879832acc4779786d764ddf2d38c5dea070f6e05c41f0d8460b8a8b11a51c35492827228740fb604
diff --git a/app-text/libspectre/files/libspectre-0.2.0-interix.patch b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
new file mode 100644
index 000000000000..7b607542dfad
--- /dev/null
+++ b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
@@ -0,0 +1,29 @@
+diff -ru libspectre-0.2.0.orig/libspectre/spectre-utils.c libspectre-0.2.0/libspectre/spectre-utils.c
+--- libspectre-0.2.0.orig/libspectre/spectre-utils.c 2008-05-06 08:35:07 +0200
++++ libspectre-0.2.0/libspectre/spectre-utils.c 2008-05-06 08:49:51 +0200
+@@ -148,6 +148,17 @@
+ spectre_strdup_vprintf (const char *format,
+ va_list args)
+ {
++#ifdef __INTERIX
++ /* no [v]asprintf here, so we need to do something else. */
++ char * string = NULL;
++ char buf[524288];
++
++ if(vsprintf(buf, format, args) < 0)
++ return NULL;
++
++ string = strdup(buf);
++ return string;
++#else
+ char *string = NULL;
+ int len = vasprintf (&string, format, args);
+
+@@ -155,6 +166,7 @@
+ string = NULL;
+
+ return string;
++#endif
+ }
+
+ char *
diff --git a/app-text/libspectre/libspectre-0.2.6.ebuild b/app-text/libspectre/libspectre-0.2.6.ebuild
new file mode 100644
index 000000000000..b5301c96d826
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A library for rendering Postscript documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="http://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc static-libs"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.62"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+DOCS="NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
+ eautoreconf # need new libtool for interix
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug asserts) \
+ $(use_enable debug checks) \
+ $(use_enable static-libs static) \
+ --disable-test
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-text/libspectre/libspectre-0.2.7.ebuild b/app-text/libspectre/libspectre-0.2.7.ebuild
new file mode 100644
index 000000000000..920dab4b4826
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A library for rendering Postscript documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="http://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc static-libs"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.62"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+DOCS="NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
+ eautoreconf # need new libtool for interix
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug asserts) \
+ $(use_enable debug checks) \
+ $(use_enable static-libs static) \
+ --disable-test
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-text/libspectre/metadata.xml b/app-text/libspectre/metadata.xml
new file mode 100644
index 000000000000..9879e83b822e
--- /dev/null
+++ b/app-text/libspectre/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>