summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-10-26 00:18:38 -0600
committerTim Harder <radhermit@gentoo.org>2020-10-26 00:19:51 -0600
commitb87d7b3eb8186790ca7a9dd537d5bc7fd2d8f820 (patch)
tree1a385c42bcd254b0112cdd43e8de5a406a603654 /app-text/llpp/llpp-33.ebuild
parentdev-ml/lablgl: remove old (diff)
downloadgentoo-b87d7b3eb8186790ca7a9dd537d5bc7fd2d8f820.tar.gz
gentoo-b87d7b3eb8186790ca7a9dd537d5bc7fd2d8f820.tar.bz2
gentoo-b87d7b3eb8186790ca7a9dd537d5bc7fd2d8f820.zip
app-text/llpp: version bump to 33
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-text/llpp/llpp-33.ebuild')
-rw-r--r--app-text/llpp/llpp-33.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-text/llpp/llpp-33.ebuild b/app-text/llpp/llpp-33.ebuild
new file mode 100644
index 000000000000..5161e2bfb42d
--- /dev/null
+++ b/app-text/llpp/llpp-33.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="Graphical PDF viewer which aims to superficially resemble less(1)"
+HOMEPAGE="https://github.com/moosotc/llpp"
+SRC_URI="https://github.com/moosotc/llpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt static-libs"
+
+RDEPEND=">=app-text/mupdf-1.17.0:0=[static-libs?]
+ app-arch/bzip2[static-libs?]
+ media-libs/fontconfig:1.0[static-libs?]
+ media-libs/freetype:2[static-libs?]
+ media-libs/jbig2dec:=[static-libs?]
+ media-libs/openjpeg:2[static-libs?]
+ sys-libs/zlib[static-libs?]
+ virtual/jpeg:0[static-libs?]
+ x11-libs/libX11[static-libs?]
+ x11-libs/libXau[static-libs?]
+ x11-libs/libXdmcp[static-libs?]
+ x11-misc/xsel"
+DEPEND="${RDEPEND}
+ dev-ml/lablgl[glut,ocamlopt?]"
+BDEPEND="
+ >=dev-lang/ocaml-4.09[ocamlopt?]
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+src_prepare() {
+ default
+
+ # use custom makefile from archlinux with minor changes
+ cp "${FILESDIR}"/${P}-makefile "${S}"/Makefile || die
+
+ # re-add desktop file removed upstream
+ cp "${FILESDIR}"/llpp.desktop "${S}"/misc || die
+
+ # remove empty interface definition
+ rm "${S}"/main.mli || die
+}
+
+src_compile() {
+ emake -j1 VERSION=${PV} CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README Thanks
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}