summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-02 13:51:21 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-02 13:53:34 +0100
commit4e052834b275d58a120045487692c74e3d094385 (patch)
treeff8062c609b6117dc5662443dbf543dffe996388 /app-text/nuspell
parentdev-python/bluelet: Stabilize 0.2.0 amd64, #749912 (diff)
downloadgentoo-4e052834b275d58a120045487692c74e3d094385.tar.gz
gentoo-4e052834b275d58a120045487692c74e3d094385.tar.bz2
gentoo-4e052834b275d58a120045487692c74e3d094385.zip
app-text/nuspell: 4.0.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-4.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index a1804fdba0c1..3510812e1b34 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,2 +1,3 @@
DIST nuspell-3.1.2.tar.gz 379029 BLAKE2B 80f773ffdcbfbeee0dd13cd325bb4fec5efa5b54ece92ac1589c418aab46c925419e9e1bc7e257a8320e24399f49bb867600679e34a5e40070b01a660578c92c SHA512 ed5206cb9ffa7e4ec6843988a75627d4ae7d5170444b6e7bd3496c1bf61c25412c4e68864800f2ad238d014b4e50d25282f367de2900f8a230f3ecc9ae5772be
DIST nuspell-4.0.0.tar.gz 379136 BLAKE2B 90aebe8318cd28240dfb7c1b034b2c045ac208c6d25344a3f2fc2f1a38995a1d6f81e70399c644c70255fbbb30f61e340808d1a71dfccab1726f89b742cf7b65 SHA512 2b08e30c4ac91a243c74f21eaf4a8d55d8b1c834e0f293fea76a9f02660f2ee89fe4d4071b1b9ed97b8c1db80b0645c71f8746738d97fc3ae779a65dc1583d3b
+DIST nuspell-4.0.1.tar.gz 379342 BLAKE2B be52797ddd737c523a6141fc1c2683690cfcd1aa09e6548d7eed593ab023d2b45d3538f2a9964a7c2b4abc6506c67058cdc2479ec12ae5438ffe9faa00f0680c SHA512 122616fd24c2de35000ba12d680d3617e7fe97881d33febbcb106ce70d3bac356a00d90680a1bc8ee631ed532ace0f4b4f9fce4760a25b0f7fc1d60553e74528
diff --git a/app-text/nuspell/nuspell-4.0.1.ebuild b/app-text/nuspell/nuspell-4.0.1.ebuild
new file mode 100644
index 000000000000..eae5d180a1bc
--- /dev/null
+++ b/app-text/nuspell/nuspell-4.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/4" # due to libnuspell.so.4
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}