summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-02-13 16:29:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-02-13 17:06:47 +0100
commit94ef3545057db1a4718a9b1fefba6417f4b2a5aa (patch)
treee99c1b7ffd31aefc07ad252cfc3e958add82724f /app-text/paperwork/paperwork-1.1.1.ebuild
parentapp-text/paperwork-backend: 1.1.1 bump (diff)
downloadgentoo-94ef3545057db1a4718a9b1fefba6417f4b2a5aa.tar.gz
gentoo-94ef3545057db1a4718a9b1fefba6417f4b2a5aa.tar.bz2
gentoo-94ef3545057db1a4718a9b1fefba6417f4b2a5aa.zip
app-text/paperwork: 1.1.1 bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/paperwork/paperwork-1.1.1.ebuild')
-rw-r--r--app-text/paperwork/paperwork-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/paperwork/paperwork-1.1.1.ebuild b/app-text/paperwork/paperwork-1.1.1.ebuild
new file mode 100644
index 000000000000..c5dd217d1cde
--- /dev/null
+++ b/app-text/paperwork/paperwork-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://github.com/jflesch/paperwork"
+SRC_URI="https://github.com/jflesch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinsane:2[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ dev-util/glade[introspection,python]
+ x11-libs/gtk+:3[introspection]"
+DEPEND="${RDEPEND}"