summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 04:12:40 +0100
committerSam James <sam@gentoo.org>2022-10-02 04:13:39 +0100
commitf12b8ad09be64a20685b7c87fdb4dbbc2b7f8a56 (patch)
tree4da177d31fd91bc237c669e727bc0a92f7485a53 /app-text/poppler-data/poppler-data-0.4.11-r2.ebuild
parentsys-apps/systemd-utils: add 251.5 (diff)
downloadgentoo-f12b8ad09be64a20685b7c87fdb4dbbc2b7f8a56.tar.gz
gentoo-f12b8ad09be64a20685b7c87fdb4dbbc2b7f8a56.tar.bz2
gentoo-f12b8ad09be64a20685b7c87fdb4dbbc2b7f8a56.zip
app-text/poppler-data: fix extra file paths
Closes: https://bugs.gentoo.org/844115 Closes: https://bugs.gentoo.org/851141 Closes: https://bugs.gentoo.org/873889 Fixes: f7d3daf96af5d450b3f983df77129c5aeac3c376 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/poppler-data/poppler-data-0.4.11-r2.ebuild')
-rw-r--r--app-text/poppler-data/poppler-data-0.4.11-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/poppler-data/poppler-data-0.4.11-r2.ebuild b/app-text/poppler-data/poppler-data-0.4.11-r2.ebuild
new file mode 100644
index 000000000000..3d7a975e6b0e
--- /dev/null
+++ b/app-text/poppler-data/poppler-data-0.4.11-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+POPPLER_DATA_EXTRA_VERSION="0.4.11-2"
+DESCRIPTION="Data files for poppler to support uncommon encodings without xpdfrc"
+HOMEPAGE="https://poppler.freedesktop.org/"
+SRC_URI="https://poppler.freedesktop.org/${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-${POPPLER_DATA_EXTRA_VERSION}-extra.tar.xz"
+
+# AGPL-3+ for the extra files needed by ghostscript, bug #844115
+LICENSE="AGPL-3+ BSD GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+src_install() {
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+
+ # We need to include extra cMaps for ghostscript, bug #844115
+ cp "${WORKDIR}"/${PN}-${POPPLER_DATA_EXTRA_VERSION}-extra/Identity-* "${ED}"/usr/share/poppler/cMap || die
+
+ # bug #409361
+ dodir /usr/share/poppler/cMaps
+ cd "${ED}"/usr/share/poppler/cMaps || die
+ find ../cMap -type f -exec ln -s {} . \; || die
+}