summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/rhyme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/rhyme')
-rw-r--r--app-text/rhyme/Manifest1
-rw-r--r--app-text/rhyme/metadata.xml18
-rw-r--r--app-text/rhyme/rhyme-0.9-r1.ebuild45
3 files changed, 64 insertions, 0 deletions
diff --git a/app-text/rhyme/Manifest b/app-text/rhyme/Manifest
new file mode 100644
index 000000000000..f0e9de7174a0
--- /dev/null
+++ b/app-text/rhyme/Manifest
@@ -0,0 +1 @@
+DIST rhyme-0.9.tar.gz 896013 SHA256 11d4862cc3adfc18ea83ca233854c562fcebdc838fa7fb62de6ef3f63f992bd4 SHA512 a769313c4790eae94eca1ecf8c00459b9d74e6437d339f8dc9f6642eea51258a0fc2541877a68eeb3a897c29877b673be17826450c1da5a2352a61266784d0fb WHIRLPOOL a2751ec43dffaa1efa8ad62a29f75c3f69d9558226c321085d583e5abdfb34910bb1a682c0ee9bb3d409cbe324294933188004bd5cb16f51b3ddfcedc3e2e6ac
diff --git a/app-text/rhyme/metadata.xml b/app-text/rhyme/metadata.xml
new file mode 100644
index 000000000000..432aed60b3c8
--- /dev/null
+++ b/app-text/rhyme/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ What is this thing? Why it's a rhyming dictionary, of course! But more
+ specifically, it's a command-line program that takes a word and returns
+ to you a formatted list of all words that rhyme with it. The default
+ response is a perfect rhyme (which is probably what you want). Or you
+ can get a syllable count of a certain word ("whitening" has 2-3
+ syllables, etc.).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">rhyme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/rhyme/rhyme-0.9-r1.ebuild b/app-text/rhyme/rhyme-0.9-r1.ebuild
new file mode 100644
index 000000000000..adce0c1beeaa
--- /dev/null
+++ b/app-text/rhyme/rhyme-0.9-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+# missing files ...
+RESTRICT="test"
+
+DESCRIPTION="Console based Rhyming Dictionary"
+HOMEPAGE="http://rhyme.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhyme/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-libs/readline-4.3
+ >=sys-libs/gdbm-1.8.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # termcap is used by default, switch to ncurses
+ sed -i Makefile \
+ -e 's|-ltermcap||g' \
+ -e 's|-o rhyme|$(LDFLAGS) &|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ # Disable parallell building wrt bug #125967
+ emake -j1 CC="$(tc-getCC)" FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # author doesnt use -D for install
+ dodir /usr/share/rhyme /usr/bin /usr/share/man/man1
+
+ einstall BINPATH="${D}"/usr/bin \
+ MANPATH="${D}"/usr/share/man/man1 \
+ RHYMEPATH="${D}"/usr/share/rhyme
+}