summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-10-19 04:40:35 -0500
committerMichał Górny <mgorny@gentoo.org>2018-10-22 22:23:22 +0200
commit18aea3ed22266338ab3395c557ad03faa900e5eb (patch)
treef92159149bf18a84a9ef286efb1ed9ac8c9492ef /app-text/scdoc
parentapp-text/scdoc: fix cross-compile, prefix install. (diff)
downloadgentoo-18aea3ed22266338ab3395c557ad03faa900e5eb.tar.gz
gentoo-18aea3ed22266338ab3395c557ad03faa900e5eb.tar.bz2
gentoo-18aea3ed22266338ab3395c557ad03faa900e5eb.zip
app-text/scdoc: bump to 1.5.2
Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text/scdoc')
-rw-r--r--app-text/scdoc/Manifest1
-rw-r--r--app-text/scdoc/scdoc-1.5.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/scdoc/Manifest b/app-text/scdoc/Manifest
index 05827d9e875c..b8b67b3ba34c 100644
--- a/app-text/scdoc/Manifest
+++ b/app-text/scdoc/Manifest
@@ -1 +1,2 @@
DIST scdoc-1.3.1.tar.gz 9392 BLAKE2B 609f25252f0ee864ba3500961aa1048c6490278f4861fb4494ca62365a20d0cb128e53a6397bd089bd5a37f25f7f3c080f6921f1c4f4ca7e4af729c87e1994fc SHA512 6064de8c76eb959708b32e93634223565e5d4b390069d4fcd2d87d27bb472a333c60b21de87d676eb57ff5f8ed6445d3c3bd92dfe7dd611f9886abc38e8d21d2
+DIST scdoc-1.5.2.tar.gz 10542 BLAKE2B 07ceb1b3b57026a4e67e575f02042c2c882cdbd29712a4d3726ff39b4356bb63a35a99b21dd68fee31aad6fb2df14b1886bb2694098bc9096c5ff9e41600e7c4 SHA512 755c1c7fbae6cbeb75ca2aa2498cb3b2cf644e5118188c3e4a4636d74764b475b1818dcb5bd08ff70e017af9c1f8cb2e351db36a2cc98885724731e4247201eb
diff --git a/app-text/scdoc/scdoc-1.5.2.ebuild b/app-text/scdoc/scdoc-1.5.2.ebuild
new file mode 100644
index 000000000000..3c018008f000
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -e 's/-Werror//' \
+ -i Makefile || die 'Failed to patch Makefile'
+}
+
+src_compile() {
+ local MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
+ CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+ emake LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" install
+}