summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 12:07:19 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:11:27 +0300
commit03dd898962f115338f26ba8e4ad8abbcbe55dd98 (patch)
tree6d7dc5383e0b518c6ecf8fbb11ab93048cbac332 /app-text
parentmate-extra/mate-netbook: Version bump (v1.22.0) (diff)
downloadgentoo-03dd898962f115338f26ba8e4ad8abbcbe55dd98.tar.gz
gentoo-03dd898962f115338f26ba8e4ad8abbcbe55dd98.tar.bz2
gentoo-03dd898962f115338f26ba8e4ad8abbcbe55dd98.zip
app-text/atril: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-text')
-rw-r--r--app-text/atril/Manifest1
-rw-r--r--app-text/atril/atril-1.22.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-text/atril/Manifest b/app-text/atril/Manifest
index ab50f26d46fb..710e96747618 100644
--- a/app-text/atril/Manifest
+++ b/app-text/atril/Manifest
@@ -1 +1,2 @@
DIST atril-1.18.3.tar.xz 1695960 BLAKE2B 2479ddd46104153631d34070054e9ba72956468c7b720aa5dc3c4a458a00cc00484cdfefb01981f2e8beeb7a13f1fc3db940dcc9a728863a1378b5b896e71e57 SHA512 d57cf4386651cb871455b003482e896a2735fb023e0b11f192ed1d169e364306f9ba55ef163df02ffd236b5f86d6afe2c1068d00d3fbc309807ded729ce2355a
+DIST atril-1.22.0.tar.xz 1819580 BLAKE2B 6d5ae9e42407c5c7ae716c0650eda2085bc2206f442dbbb04dbf549263cdabe6d28761deb14bb9557534f26828882cf5b9373698b5e2c29f4b70445ebfabaa5b SHA512 bf940178647c348fd78e828bcb3a55c4ff6195d4020bf198ae5ba4a96e2fe582f7e30fb9d4cde4143e82ae783358373d3a9fd68413295586da9fe1b374e2f034
diff --git a/app-text/atril/atril-1.22.0.ebuild b/app-text/atril/atril-1.22.0.ebuild
new file mode 100644
index 000000000000..46a5316bd205
--- /dev/null
+++ b/app-text/atril/atril-1.22.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Atril document viewer for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="caja dbus debug djvu dvi epub +introspection gnome-keyring +postscript t1lib tiff xps"
+
+REQUIRED_USE="t1lib? ( dvi )"
+
+COMMON_DEPEND=">=app-text/poppler-0.22[cairo]
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ >=x11-libs/libSM-1:0
+ x11-libs/libX11
+ >=x11-libs/cairo-1.9.10
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1[introspection?] )
+ djvu? ( >=app-text/djvu-3.5.17:0 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5:5 )
+ )
+ epub? (
+ dev-libs/mathjax
+ >=net-libs/webkit-gtk-2.4.3:4
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6:= )
+ postscript? ( >=app-text/libspectre-0.2 )
+ tiff? ( >=media-libs/tiff-3.6 )
+ xps? ( >=app-text/libgxps-0.2.1 )
+ !!app-text/mate-document-viewer"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/rarian
+ app-text/yelp-tools
+ >=app-text/scrollkeeper-dtd-1:1.0
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig:*
+ sys-devel/gettext:*"
+
+# Tests use dogtail which is not available on Gentoo.
+RESTRICT="test"
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ mate_src_configure \
+ --disable-tests \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-previewer \
+ --enable-thumbnailer \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable caja) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable epub) \
+ $(use_enable introspection) \
+ $(use_enable postscript ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}