summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 12:07:12 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:42:56 +0200
commit204dca8901a6120511bdc4e2a0b3d0667f5314cc (patch)
tree4b8216bbb5199d3ef2578a97d53c564958c2e0ff /app-text
parentapp-text/evince: Drop old (diff)
downloadgentoo-204dca8901a6120511bdc4e2a0b3d0667f5314cc.tar.gz
gentoo-204dca8901a6120511bdc4e2a0b3d0667f5314cc.tar.bz2
gentoo-204dca8901a6120511bdc4e2a0b3d0667f5314cc.zip
app-text/evince: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/Manifest1
-rw-r--r--app-text/evince/evince-3.20.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-text/evince/Manifest b/app-text/evince/Manifest
index bd430105d0f9..2fc1706858b3 100644
--- a/app-text/evince/Manifest
+++ b/app-text/evince/Manifest
@@ -1 +1,2 @@
DIST evince-3.18.2.tar.xz 3159888 SHA256 42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17 SHA512 9d73d23de18f89034bf3ba1f18aba37316ddd6304370f3442a39c62d95a3443a51b1b7c641616f7b2d2d4deb316f0ea5246650eee3e4458a2356c9f2b2406fe6 WHIRLPOOL 01fd8d0289319c6cd41ee2581a896428f483c960c4f73417102f0697900fe14418ffdcc5811e8f3cfe7be881df54b97f6d8bb840e81db06fa61fc8c9f0ea29da
+DIST evince-3.20.1.tar.xz 3352756 SHA256 fc7ac23036939c24f02e9fed6dd6e28a85b4b00b60fa4b591b86443251d20055 SHA512 33f50627f26f241ea94a05cf421363f56439c35169e7beb1555885cd7641a8bb5a50af6710143c66d21220dcd1dc9e1f00bd902b9e2c64a6a6fa1243a5e2eb60 WHIRLPOOL c579dc34550bc5885d696a82adc93470109c1aef9a75bcbcc3c9886cf8d76fe354c3053289f273530f78551e1ce5245a4828c9c626d3058289c548a7b17b1493
diff --git a/app-text/evince/evince-3.20.1.ebuild b/app-text/evince/evince-3.20.1.ebuild
new file mode 100644
index 000000000000..a37bfe1543de
--- /dev/null
+++ b/app-text/evince/evince-3.20.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
+IUSE="djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin +postscript t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# atk used in libview
+# gdk-pixbuf used all over the place
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.36:2[dbus]
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib:=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.16.0:3[introspection?]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.10:=
+ >=app-text/poppler-0.33:=[cairo]
+ djvu? ( >=app-text/djvu-3.5.22:= )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea:=
+ t1lib? ( >=media-libs/t1lib-5:= ) )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0 )
+ gnome? ( gnome-base/gnome-desktop:3= )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ postscript? ( >=app-text/libspectre-0.2:= )
+ tiff? ( >=media-libs/tiff-3.6:0= )
+ xps? ( >=app-text/libgxps-0.2.1:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs
+ gnome-base/librsvg
+ || (
+ >=x11-themes/adwaita-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not depend on adwaita-icon-theme, bug #326855, #391859
+ # https://bugs.freedesktop.org/show_bug.cgi?id=29942
+ sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
+ -i configure || die "sed failed"
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-pdf \
+ --enable-comics \
+ --enable-thumbnailer \
+ --with-platform=gnome \
+ --enable-dbus \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable gstreamer multimedia) \
+ $(use_enable gnome libgnome-desktop) \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable postscript ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps) \
+ BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
+}