summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-25 10:57:11 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-25 10:57:39 -0600
commit2dea256ca4aa52a84ad01dc3f7dfe1067e304bce (patch)
tree12846ffc2b712fb24d3e0f6237a79022b02be80b /app-text
parentnet-wireless/unifi: bump to 6.1.60, drop old (diff)
downloadgentoo-2dea256ca4aa52a84ad01dc3f7dfe1067e304bce.tar.gz
gentoo-2dea256ca4aa52a84ad01dc3f7dfe1067e304bce.tar.bz2
gentoo-2dea256ca4aa52a84ad01dc3f7dfe1067e304bce.zip
app-text/wgetpaste: fix dpaste escapes
Without this fix, all spaces are converted to "+", and more Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wgetpaste/files/wgetpaste-2.30-fix-dpaste-escapes.patch13
-rw-r--r--app-text/wgetpaste/wgetpaste-2.30_p20210222-r2.ebuild32
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/wgetpaste/files/wgetpaste-2.30-fix-dpaste-escapes.patch b/app-text/wgetpaste/files/wgetpaste-2.30-fix-dpaste-escapes.patch
new file mode 100644
index 000000000000..b4d57f843c96
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-2.30-fix-dpaste-escapes.patch
@@ -0,0 +1,13 @@
+diff --git a/wgetpaste b/wgetpaste
+index 0f8219b..ed0bdac 100755
+--- a/wgetpaste
++++ b/wgetpaste
+@@ -110,6 +110,8 @@ Python Python%Interactive/Traceback Ruby Ruby%HTML%(ERB) SQL XML"
+ LANGUAGE_VALUES_dpaste="% Apache Bash Css Diff DjangoTemplate Haskell JScript Python PythonConsole \
+ Ruby Rhtml Sql Xml"
+ EXPIRATIONS_dpaste=$(printf "%s " {1..365})
++escape_description_dpaste() { echo "$*"; }
++escape_input_dpaste() { echo "$*"; }
+ POST_dpaste() {
+ local title="${2}"
+ local syntax="${3}"
diff --git a/app-text/wgetpaste/wgetpaste-2.30_p20210222-r2.ebuild b/app-text/wgetpaste/wgetpaste-2.30_p20210222-r2.ebuild
new file mode 100644
index 000000000000..c4c95081e20e
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.30_p20210222-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+
+COMMIT_HASH="f9b08c50009485817e8b44300f79a92e37fe9f22"
+SRC_URI="https://github.com/zlin/wgetpaste/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ssl"
+
+RDEPEND="net-misc/wget[ssl?]"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+PATCHES=( "${FILESDIR}/wgetpaste-2.30-fix-dpaste-escapes.patch" )
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}