summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-09-27 22:52:57 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-09-27 22:52:57 +0900
commit579e7cb763dded98f3cf5d66d677372a4bf03bef (patch)
tree4a6aa6e491242e0cf464658d808779f762287c04 /app-text
parentapp-emulation/cri-tools: Version bump to 1.16.1 (diff)
downloadgentoo-579e7cb763dded98f3cf5d66d677372a4bf03bef.tar.gz
gentoo-579e7cb763dded98f3cf5d66d677372a4bf03bef.tar.bz2
gentoo-579e7cb763dded98f3cf5d66d677372a4bf03bef.zip
app-text/po4a: new upstream release
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/po4a-0.56.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index cdaaf5c85685..ae584af01d07 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,3 +1,4 @@
DIST po4a-0.54.tar.gz 2686485 BLAKE2B f33f1e27bd24e4429ef8edbdd999333714e9a50e4af2c60ccffec91098bf330776c4ee9de9b6d4cdb459b67a26a1a6e4b8a0ead7efa82fe97584405a15245ef4 SHA512 5d97a169c73bcb872247599af477ecca9112b9ff576dfb93a2aa06b9891464a1837d799304f1a3ea8344ad46a4529ec19568584b7914761deccc09a9099e3130
DIST po4a-0.55.tar.gz 2892158 BLAKE2B 606236a4bc143d4a5cc003f7dfaf59f605017478fc7ab3fc66af5eed078a8bb0744690b7191cd2ee0b795229e766145ed47545484e3d20e6a14ae1ac0981772a SHA512 95f7408caf2c603f2ea86d8439e99c39be72dca019361106190bd6e1f95679c6627280bcd02a2d9c843071a6ce96747bf5b4d85c9051344b08f32deade2cb599
+DIST po4a-0.56.tar.gz 2994792 BLAKE2B c95905c70d7e1e24367fb128d9096996d026f58dd4cd7fa77f19c6c9b8607cb4101a1a024773d2fd383e905a008e1ce4f0c019a73003168a90cb23328ac1d984 SHA512 4fc1ca5743471577d9e8bd0b80285b9dbd83b964f8e828472787a6deaf8b8388bb7f96e68afab4119c1f5488fe371d3b1fa94b101204a59228d1cc2f0878f3c1
DIST po4a_0.47.orig.tar.gz 2389750 BLAKE2B 72cd81e10f638a660e201b0c733b08c316aa75dd29b054bbc4c645c265b9e7745ce762305a8296f8cc37d2f182755dfa1394861f6c471cff1c7c398d13ac28cc SHA512 9c459a9795977a39aacc09cfb6ddbdc7dd2174e22896fa7bde90510a43ea833054aef558f7ca798991addc052a2c7f91ee11e5d49658a5c80a9ecb9c135ff97a
diff --git a/app-text/po4a/po4a-0.56.ebuild b/app-text/po4a/po4a-0.56.ebuild
new file mode 100644
index 000000000000..c4c7d79c9443
--- /dev/null
+++ b/app-text/po4a/po4a-0.56.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PLOCALES="af ar ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt pt_BR ru sl sv uk vi zh_CN zh_HK"
+
+inherit perl-module l10n
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/SGMLSpm
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
+PERL_RM_FILES=(
+ t/09-html.t
+)
+DIST_TEST="do"
+
+src_prepare() {
+ l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ l10n_for_each_disabled_locale_do rm_locale
+
+ perl-module_src_prepare
+}