summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoão Santos <joaompssantos@gmail.com>2019-02-02 10:03:45 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 19:28:55 +0100
commit618e13ee848145e2ea1461288feb16a72fa36afc (patch)
tree06cb2a6de5b5c0b6d3b72eaa27bd8abd3451c0bd /app-text
parentapp-text/master-pdf-editor: removed 5.2.00 version (diff)
downloadgentoo-618e13ee848145e2ea1461288feb16a72fa36afc.tar.gz
gentoo-618e13ee848145e2ea1461288feb16a72fa36afc.tar.bz2
gentoo-618e13ee848145e2ea1461288feb16a72fa36afc.zip
app-text/master-pdf-editor: version bump to 5.3.05
Signed-off-by: João Santos <joaompssantos@gmail.com> Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.3.02.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index b3a38be9e91b..464216995eee 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1 +1,2 @@
DIST master-pdf-editor-5.2.20_qt5.amd64.tar.gz 16261577 BLAKE2B 112c8d308875d36e3a71d28ae407eb78a0f714383fc005dc020cdb911a5596548274a55466133d8e03cbf47df29c062973f243f88ad0b1e9caa8410fbdfe2b8d SHA512 85b095603da1114cd4749ddbcf7bdd513c868ee17434df47037f7e0b914546fd13a6911949579ee981b5c33dcb13eb0ffa9585d4cbedd9bff4dc56e32bdcf4cb
+DIST master-pdf-editor-5.3.02_qt5.amd64.tar.gz 16333023 BLAKE2B 99c1291cd5d354e304e873dd2528806898109f0a9a79c87eb89394ec8300ab692294c5b04fa7fb712df82fa683cd3ed549b9842417d2b13f6a3f5f41fcfa334e SHA512 bf1118f1eefe3f46addacba832eee757112a91154de5929c825845983e7b6bc681bff84501082e696bb14acf6652ea180912ae48a0dfea270053fc42a3200448
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.3.02.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.3.02.ebuild
new file mode 100644
index 000000000000..c1a2f781209e
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.3.02.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils desktop
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+ >=dev-qt/qtsvg-5.4.1:5
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}