summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-03-06 19:37:01 -0500
committerAaron Bauman <bman@gentoo.org>2019-03-06 19:37:36 -0500
commit8cb74167f164fa3f69aeefce4af2026f733f6219 (patch)
tree000725cdee73f32915116f26bb262b7cc54acc77 /app-text
parentsys-kernel/gentoo-sources: ppc:Simplify vr_get/set() to avoid GCC warning (diff)
downloadgentoo-8cb74167f164fa3f69aeefce4af2026f733f6219.tar.gz
gentoo-8cb74167f164fa3f69aeefce4af2026f733f6219.tar.bz2
gentoo-8cb74167f164fa3f69aeefce4af2026f733f6219.zip
app-text/scdoc: fix pkgconfig install path
Signed-off-by: Aaron Bauman <bman@gentoo.org> Bug: https://bugs.gentoo.org/679228 Bug: https://bugs.gentoo.org/679508 Package-Manager: Portage-2.3.62, Repoman-2.3.12
Diffstat (limited to 'app-text')
-rw-r--r--app-text/scdoc/scdoc-1.9.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/scdoc/scdoc-1.9.3-r1.ebuild b/app-text/scdoc/scdoc-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..119be54bf057
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.9.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -e 's/-Werror//' \
+ -i Makefile || die 'Failed to patch Makefile'
+}
+
+src_compile() {
+ local MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
+ CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+ emake LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
+ PCDIR="${ED}/usr/$(get_libdir)/pkgconfig" install
+}