summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-02-13 20:21:24 +0100
committerFabian Groffen <grobian@gentoo.org>2020-02-13 20:21:39 +0100
commitc9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9 (patch)
tree872703b155082fb3d0575acfcbf99c28817783fe /app-text
parentsys-apps/util-linux: Don't RDEPEND on virtual/os-headers (diff)
downloadgentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.tar.gz
gentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.tar.bz2
gentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.zip
app-text/vilistextum-2.8.0.20191023-r1: add fix for list alignment
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch43
-rw-r--r--app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild (renamed from app-text/vilistextum/vilistextum-2.8.0.20191023.ebuild)1
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch b/app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch
new file mode 100644
index 000000000000..c308cfe1615f
--- /dev/null
+++ b/app-text/vilistextum/files/vilistextum-2.8.0-list-alignment.patch
@@ -0,0 +1,43 @@
+--- a/src/lists.c
++++ b/src/lists.c
+@@ -74,6 +74,7 @@
+ }
+
+ spaces += tab;
++ orderedlist++;
+ #ifdef proc_debug
+ printf("start_uls() ende\n");
+ #endif
+@@ -82,6 +83,7 @@
+ void end_uls()
+ {
+ spaces -= tab;
++ orderedlist--;
+ line_break();
+
+ if (bullet_style=='%') { bullet_style='$'; }
+--- a/src/text.c
++++ b/src/text.c
+@@ -387,7 +387,11 @@
+ }
+ i=0;
+ while (i<spaces) { zeile_plus_wort(ONESPACE,1,1); i++; }
+- if (orderedlist>0) { zeile_plus_wort(ONESPACE,1,1); }
++ if (orderedlist>0)
++ {
++ i=(spaces%tab) + 1;
++ while (i>0) { zeile_plus_wort(ONESPACE,1,1); i--; }
++ }
+ zeile_plus_wort(wort, wort_len, wort_pos);
+ }
+ else if (zeilen_len != 0)
+--- a/src/text.h
++++ b/src/text.h
+@@ -27,6 +27,7 @@
+ int tab;
+ int spaces;
+ int quote;
++int orderedlist;
+
+ void print_zeile();
+ int is_zeile_empty();
diff --git a/app-text/vilistextum/vilistextum-2.8.0.20191023.ebuild b/app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
index d77ae962a94b..2396c7dc0d6f 100644
--- a/app-text/vilistextum/vilistextum-2.8.0.20191023.ebuild
+++ b/app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
@@ -24,6 +24,7 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-2.8.0-prefix.patch"
eapply "${FILESDIR}/${PN}-2.8.0-blockquote.patch"
eapply "${FILESDIR}/${PN}-2.8.0-towlower.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-list-alignment.patch"
eapply_user
eautoreconf