summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-21 01:01:26 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-21 01:47:54 -0600
commitf9e09c7cdd76131ef0925266fa4aa06bd2cd3dbc (patch)
treea226f663ff62e61e5188b4a4a11c497af9ce6276 /app-text
parentdev-ml/camlpdf: version bump to 2.2.1 (diff)
downloadgentoo-f9e09c7cdd76131ef0925266fa4aa06bd2cd3dbc.tar.gz
gentoo-f9e09c7cdd76131ef0925266fa4aa06bd2cd3dbc.tar.bz2
gentoo-f9e09c7cdd76131ef0925266fa4aa06bd2cd3dbc.zip
app-text/cpdf: version bump to 2.2.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cpdf/Manifest1
-rw-r--r--app-text/cpdf/cpdf-2.2.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/cpdf/Manifest b/app-text/cpdf/Manifest
index 4b5b9d4c9d23..610aa4c715ab 100644
--- a/app-text/cpdf/Manifest
+++ b/app-text/cpdf/Manifest
@@ -1 +1,2 @@
DIST cpdf-2.1.1.tar.gz 349536 BLAKE2B 4064605890745ebaa24d32c3294a3293312dc8df6ab3989e1a7417989cdb19aca6b70faafb258c7c00d6febeba8b17379396c1f90628e72be0791cdefc579b6f SHA512 aa06efaf098d3fe3f560ea30da9c3546e13d294b22d61c4cc3df553eb90e338d59ee1b51d14d7982ce52967bcf98c2afec9a5b5ae101e2183961f4be862c6517
+DIST cpdf-2.2.1.tar.gz 704730 BLAKE2B 1767d2c9fdc645b4ff97b828b1d7bedb22aa645444f299e36ec4717015ea7b87dbbac4c9ec27bb508a7adb28b2c75c155bf9094a168567abbffa93887712241d SHA512 3dda72513c551cca5d8cb60732b3f2c2e8ad400bd2c9fcf0c3b54a68e94385e3f19ec7713de95efa90eafb7b0077662097565a28616041019e03edf140b6af4f
diff --git a/app-text/cpdf/cpdf-2.2.1.ebuild b/app-text/cpdf/cpdf-2.2.1.ebuild
new file mode 100644
index 000000000000..f65bcfcc2166
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="http://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt]
+ dev-ml/camlpdf:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md cpdfmanual.pdf
+ doman cpdf.1
+
+ use doc && dodoc -r doc/cpdf/html
+}