summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-24 19:38:56 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-24 20:09:50 -0400
commit2b1813df5a0aa2bb26fe224d838f8195d13e61e5 (patch)
tree8bf1cec6e40980ba96eb98d765ee414d13119898 /app-vim/airline
parentprofiles: update chromium mask for M67 (diff)
downloadgentoo-2b1813df5a0aa2bb26fe224d838f8195d13e61e5.tar.gz
gentoo-2b1813df5a0aa2bb26fe224d838f8195d13e61e5.tar.bz2
gentoo-2b1813df5a0aa2bb26fe224d838f8195d13e61e5.zip
app-vim/airline: version bump to 0.9
Diffstat (limited to 'app-vim/airline')
-rw-r--r--app-vim/airline/Manifest1
-rw-r--r--app-vim/airline/airline-0.9.ebuild29
-rw-r--r--app-vim/airline/airline-9999.ebuild3
3 files changed, 32 insertions, 1 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
index 22a2ad1c7d26..3f2e8b29c920 100644
--- a/app-vim/airline/Manifest
+++ b/app-vim/airline/Manifest
@@ -1 +1,2 @@
DIST airline-0.8.tar.gz 52767 BLAKE2B 908489fca1fb31d0ee41f279b146046d50c9069055bb13645b049c4333984f0ca180315e50fe3fda13e36780dffa0b213719babbbcd2b27defd60470a05dbc2f SHA512 51ae20f7e5b869f714e9c21ab6ab8af4d2de31b3cf4fe9f6bd64e75e87e7796184d41ddd9536f3e41dcc93e9ca6aad684b286df6e5d8d6eae202f91ed8851292
+DIST airline-0.9.tar.gz 72660 BLAKE2B d6c9762d8140b2a88a001b9ea3ae62c3c9147ccf3db90146d7fded8dcbc6062bf97c0725baa79db9d7bfe0eeaa5dc00ddfabde8ed1b9aec7f5aa24c41b11d1f2 SHA512 f3fd03c7ab6603eee6e892a1b88888d72fc43cf0a8582ad7e65152cddebb0d14be3a805529fa5467fc82e040cce2616f1693bf294c892c0849d9fb51cbbd04ec
diff --git a/app-vim/airline/airline-0.9.ebuild b/app-vim/airline/airline-0.9.ebuild
new file mode 100644
index 000000000000..2b0d045e241b
--- /dev/null
+++ b/app-vim/airline/airline-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ https://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index 248f1fbb3ed7..8f8c09743034 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
inherit vim-plugin
if [[ ${PV} != 9999* ]] ; then