summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/supertab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/supertab')
-rw-r--r--app-vim/supertab/Manifest1
-rw-r--r--app-vim/supertab/metadata.xml8
-rw-r--r--app-vim/supertab/supertab-2.1.ebuild19
3 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/supertab/Manifest b/app-vim/supertab/Manifest
new file mode 100644
index 000000000000..e1072e788a14
--- /dev/null
+++ b/app-vim/supertab/Manifest
@@ -0,0 +1 @@
+DIST supertab-2.1.tar.gz 16585 SHA256 203d76597f2c183de2d6583de8f3b65423cba3090dda631b51e6eec32301ce1f SHA512 6daec863968be9aaefecb3388a8626f4ebf1c76899e460463fc64a56f15f743d3eae36b03588b5450a2c49b63ecdec8faf3476eda1a07cc48caf731eff77a592 WHIRLPOOL d0928f5a78b03d5e4d06e18fa198665f3fe333f264b55fd80d7c16cc4e01dc1845847308736417bb26688111db3c1ec4cb981c329043d670664ade74171b68b0
diff --git a/app-vim/supertab/metadata.xml b/app-vim/supertab/metadata.xml
new file mode 100644
index 000000000000..b4ec7dcae796
--- /dev/null
+++ b/app-vim/supertab/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">ervandew/supertab</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/supertab/supertab-2.1.ebuild b/app-vim/supertab/supertab-2.1.ebuild
new file mode 100644
index 000000000000..76a18c32787d
--- /dev/null
+++ b/app-vim/supertab/supertab-2.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: enhanced Tab key functionality"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1643 https://github.com/ervandew/supertab/"
+SRC_URI="https://github.com/ervandew/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="amd64 ~mips ppc x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm Makefile .gitignore || die
+}