summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 23:09:37 +0100
committerSam James <sam@gentoo.org>2021-04-19 23:41:28 +0100
commitf98195b7acbaabf1c29e1932ed2fbbeea1df870a (patch)
tree93ce67559d5f695a946ac76ab2e68284b4f39f6d /app-vim/taglist/taglist-4.6.ebuild
parentapp-cdr/mp3burn: port to EAPI 7 (diff)
downloadgentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.tar.gz
gentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.tar.bz2
gentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.zip
app-vim/taglist: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim/taglist/taglist-4.6.ebuild')
-rw-r--r--app-vim/taglist/taglist-4.6.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-vim/taglist/taglist-4.6.ebuild b/app-vim/taglist/taglist-4.6.ebuild
index 9d03fdf679f7..80f6a853fddb 100644
--- a/app-vim/taglist/taglist-4.6.ebuild
+++ b/app-vim/taglist/taglist-4.6.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit vim-plugin epatch
+inherit vim-plugin
DESCRIPTION="vim plugin: ctags-based source code browser"
HOMEPAGE="http://vim-taglist.sourceforge.net/"
+
LICENSE="vim"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
@@ -14,6 +15,6 @@ RDEPEND="dev-util/ctags"
VIM_PLUGIN_HELPFILES="${PN}.txt"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.4-ebuilds.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-ebuilds.patch
+)