summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-24 23:33:41 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-24 23:33:41 -0400
commit7b7c49580b74f9e18906cf58ef8d661a96e902c6 (patch)
tree8de04189845a75d24f211735d6711f64e84faa4e /app-vim/vim-r
parentwww-client/lynx: version bump (diff)
downloadgentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.tar.gz
gentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.tar.bz2
gentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.zip
app-vim/vim-r: version bump
Diffstat (limited to 'app-vim/vim-r')
-rw-r--r--app-vim/vim-r/Manifest1
-rw-r--r--app-vim/vim-r/vim-r-1.2.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/vim-r/Manifest b/app-vim/vim-r/Manifest
index 662ed412da99..40bbac89bc2e 100644
--- a/app-vim/vim-r/Manifest
+++ b/app-vim/vim-r/Manifest
@@ -5,3 +5,4 @@ DIST vim-r-0.9.9.7.tar.bz2 126403 SHA256 4b2a95dab6d51621b31ae25edb8dbd724757bc4
DIST vim-r-0.9.9.8.tar.bz2 75236 SHA256 eb6048d872b0156a0cdc9644d48fa6eb2418f2d784698c43a1e333d40790a75f SHA512 4356ca4493b564ec0881dfc6e596983f88124f79bfd5a20483f6d3b72488807c31090f43b676abc89f3c5aefe8f533c72f22bec89ee580ff244d22b0b7d3aa4d WHIRLPOOL b0031e1a238f3c7e0b0332306d10dda5ead65abf1ead95efe2129538f15f900ed51a11a346e33e5d50c8510dcf10b0eec1645aac64fa5c0f0975e6d79c76df4d
DIST vim-r-0.9.9.9.tar.bz2 76020 SHA256 728aead76d0d70495f48b12482cdcaa590e5f9586e6298e53e6116a3676529f7 SHA512 90420a5b4f86765e4a376aef0c4008600cb010832f86c585d05248218e6736adec192d7ddccf8a581cdbb4b85e60741398023a88a213dc7c847ee078ae528078 WHIRLPOOL ab1823829e86aa9e1a308b75e015b64f49bb0284a9f80d2013697f8c07d4f31bac628f21a319451d083ea9f2355095f0a3579fe9bb5474810fa650c0e6fabd6b
DIST vim-r-1.0.tar.bz2 82116 SHA256 6836f4adc44355607d08b4bed03f4afa2359b40f95afdf685fb771a84bdbbfc9 SHA512 9df3bf35da9da6f650c3de23f0a7607e5e02a6193e1f2352d8129668d0ad37a63088a6ae7ac77831952aa7d35bde2d2d7b6f592a15dc856eaf64a1cbb5cd07cc WHIRLPOOL 9d24f09d7e3c22a0ebe71f1e65809acaffb3d8dbaf511f3703dc327706774634d9722a2093afaabb75178d8f9d62a4c51dddd0b21068089e75d647478c80f2ed
+DIST vim-r-1.2.6.tar.bz2 76361 SHA256 31881c9ea00af18786ef3bd0bb8526447c04f13b00369a6b55e2dc5a66fb6cc7 SHA512 187b31068d32c22c182650571dc5af68cc804562ffdc6b4902729735e4000b1ca4e0636d6b5617f3c2f36403eb4f0b1adc35d2387b5c110286da2ea2254f9009 WHIRLPOOL 118704ba1ce184a09569844d4a2dfeb3c66774a97ad7d4bd7ea695c176fb0093133dd54e0b4cedf49ddb74b75bd324585898a70bb8985c6893d79a2701eee06d
diff --git a/app-vim/vim-r/vim-r-1.2.6.ebuild b/app-vim/vim-r/vim-r-1.2.6.ebuild
new file mode 100644
index 000000000000..6da98773669e
--- /dev/null
+++ b/app-vim/vim-r/vim-r-1.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: integrate vim with R"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2628"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/R"
+
+VIM_PLUGIN_HELPFILES="r-plugin.txt"
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "This plugin requires the vimcom R package to be installed,"
+ elog "see https://github.com/jalvesaq/VimCom for instructions."
+ fi
+}