summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-14 19:53:18 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-14 19:58:33 +0100
commit15e0d0f6494319c7a0c7d5c1318efa7d4eaa74d0 (patch)
treecdd0e4e0a51f13b4338a9229c8d4ff0bf6a4d974 /app-vim
parentapp-eselect/eselect-postgresql: Cleanup again (diff)
downloadgentoo-15e0d0f6494319c7a0c7d5c1318efa7d4eaa74d0.tar.gz
gentoo-15e0d0f6494319c7a0c7d5c1318efa7d4eaa74d0.tar.bz2
gentoo-15e0d0f6494319c7a0c7d5c1318efa7d4eaa74d0.zip
app-vim/slimv: version bump.
Closes: https://bugs.gentoo.org/564292 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/slimv/Manifest1
-rw-r--r--app-vim/slimv/slimv-0.9.13_p20170910.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/slimv/Manifest b/app-vim/slimv/Manifest
index 75069b74123c..a89a4e8879db 100644
--- a/app-vim/slimv/Manifest
+++ b/app-vim/slimv/Manifest
@@ -1 +1,2 @@
DIST slimv-0.9.12.tar.bz2 614025 BLAKE2B 8740e905a12b28715f953fecfdde3c7d6b4eeb74fc190c433bdb7120b3a6af5d5c9c2ced3f57a43ab8b9bd1402cb15462892343bb621f8b56453d98a909ff882 SHA512 7ccf617780c5d6b8d25738546cb9df6986b4409748a5938e8d9112b057d34626a6b8525fb8622db06d0f300d6ec38f7513ef2c0e49df3bcd89614888887ca057
+DIST slimv-0.9.13_p20170910.tar.gz 634493 BLAKE2B af7963e1d1b60b20294c935ecd076220777eec333b4e91bac82a111b727ce71c312c347b865f9e0c9072c0f94b40dc920b15feaf10f8683e1bba7590a177e62e SHA512 562e08866d62a6af5c20064a4533da7f0577ceb43391fac59acc0bb9c76319e3520c951c325277edbb2d0461fa227b91456c54ec5d9d1e3bca18d344f3e9a5e2
diff --git a/app-vim/slimv/slimv-0.9.13_p20170910.ebuild b/app-vim/slimv/slimv-0.9.13_p20170910.ebuild
new file mode 100644
index 000000000000..78e20a7742e7
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.13_p20170910.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+# Commit Date: July 10th 2017
+COMMIT="acf9b30be71c54db4f4875d257b905941ca69ed8"
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="https://github.com/kovisoft/slimv"
+SRC_URI="https://github.com/kovisoft/slimv/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}
+ || (
+ dev-lisp/abcl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/clozurecl
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}