summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 21:08:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 21:08:35 +0200
commit6788cd2ffe4a0f17dadfe42246337b8d8875d82e (patch)
tree4d2ad96ad04cc12e238ca89c0a95577ec6710af7 /app-vim
parentmedia-libs/xine-lib: Stabilize 1.2.12-r1 amd64, #835838 (diff)
downloadgentoo-6788cd2ffe4a0f17dadfe42246337b8d8875d82e.tar.gz
gentoo-6788cd2ffe4a0f17dadfe42246337b8d8875d82e.tar.bz2
gentoo-6788cd2ffe4a0f17dadfe42246337b8d8875d82e.zip
app-vim/gentoo-syntax: Bump to v2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index ee91cd5b0e90..4323314ca39e 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-1.tar.bz2 20223 BLAKE2B 846e07354660b4859cc4131a9fbf4f78d3a2ddeda60fc6a3687b649788a52725602dcd22befa9ab9fe88b173eab1470e569076d587326935efaf40d3aaba5b57 SHA512 1e4d947f0edbf6bd24142d683944f30d43b7e0ca86b90311f2e80516d299d9a634a9842cdc90d98a43e7a693f0dd29b3ff8048256bc3fe688591cc2b84808289
+DIST gentoo-syntax-2.tar.bz2 20302 BLAKE2B fa15fe5e8ef547dfa402b1742df3d6d38231528bcf6c6836e4d31e81ec2bce55ffa8c10400823c97688304f9dc6324ed3d257939c3077eb29a2fc3c191295604 SHA512 30e8e374382dc736febd1ee8031a7ccc14dfc61feade1815e3366988658189ac8670ff26532436ae608ff66c828e2de7327d0b39db37967206bcd9f418d26ea2
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-2.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-2.ebuild
new file mode 100644
index 000000000000..cc256f13f274
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}