summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-11 10:52:45 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-11 10:53:49 +0000
commita313dd67cabba65fd509512a974817f717535362 (patch)
tree4ef04c13e8a01f531ffb12be6253b8b72d28d508 /app-vim
parentnet-analyzer/argus: Old. (diff)
downloadgentoo-a313dd67cabba65fd509512a974817f717535362.tar.gz
gentoo-a313dd67cabba65fd509512a974817f717535362.tar.bz2
gentoo-a313dd67cabba65fd509512a974817f717535362.zip
app-vim/pytest: Add pytest vimscript to the tree.
Gentoo-Bug: https://bugs.gentoo.org/471734 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pytest/Manifest1
-rw-r--r--app-vim/pytest/metadata.xml11
-rw-r--r--app-vim/pytest/pytest-1.1.4.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/pytest/Manifest b/app-vim/pytest/Manifest
new file mode 100644
index 000000000000..304863f90bd2
--- /dev/null
+++ b/app-vim/pytest/Manifest
@@ -0,0 +1 @@
+DIST pytest-1.1.4.tar.gz 10550 SHA256 2e4096f6339c729b6812fd789e9baa7c9ac8dda2358a1b00cbd6fe3c431d4b55 SHA512 94240b763c332e5cd46169af86c6e775993a8ec48e5ad4138cda1dcc5798e2f40f61c484a04a91f9d7a351f3f583c72e56254bda9af8843b2a99aa451d1a8930 WHIRLPOOL 26bf7954aad6d70366e3d8df170759c8b81a64670eaea0e02b2a381aaa0e90ab6688ea3fff5f3e1ae878a3cb161928d39e34f4c1312252b85985e8a3ea534c5e
diff --git a/app-vim/pytest/metadata.xml b/app-vim/pytest/metadata.xml
new file mode 100644
index 000000000000..6c8987e6f46f
--- /dev/null
+++ b/app-vim/pytest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/pytest/pytest-1.1.4.ebuild b/app-vim/pytest/pytest-1.1.4.ebuild
new file mode 100644
index 000000000000..b76d80eeed5e
--- /dev/null
+++ b/app-vim/pytest/pytest-1.1.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: run tests with py.test from within vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3424"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=18178 -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-python/pytest"
+
+S="${WORKDIR}/${PN}.vim"